Custombuild PCRE installation problem with Centos 5.2

r0kawa

Verified User
Joined
Nov 17, 2005
Messages
17
Hi,
I've tried a few times using 1.1 or 1.2 getting the same error. With the RPM version of libtool or without the rpm (using yum). The error occur at PCRE installation.

centos 5.2, xen
[root@localhost custombuild]# uname -a
Linux localhost.localdomain 2.6.18-92.el5xen #1 SMP Tue Jun 10 19:55:54 EDT 2008 i686 i686 i386 GNU/Linux

I'm using
1. ./build all d
2. ./build pcre

both result with the same error.

Bellow is the error.


Code:
mv -f .deps/pcreposix.Tpo .deps/pcreposix.Plo
/bin/sh ./libtool --tag=CC   --mode=link gcc  -O2 -version-info 0:0:0  -o libpcreposix.la -rpath /usr/local/lib pcreposix.lo libpcre.la
gcc -shared  .libs/pcreposix.o  -Wl,--rpath -Wl,/usr/local/directadmin/custombuild/pcre-7.8/.libs ./.libs/libpcre.so  -Wl,-soname -Wl,libpcreposix.so.0 -o .libs/libpcreposix.so.0.0.0
(cd .libs && rm -f libpcreposix.so.0 && ln -s libpcreposix.so.0.0.0 libpcreposix.so.0)
(cd .libs && rm -f libpcreposix.so && ln -s libpcreposix.so.0.0.0 libpcreposix.so)
ar cru .libs/libpcreposix.a  pcreposix.o
ranlib .libs/libpcreposix.a
creating libpcreposix.la
(cd .libs && rm -f libpcreposix.la && ln -s ../libpcreposix.la libpcreposix.la)
source='pcrecpp.cc' object='pcrecpp.lo' libtool=yes \
        DEPDIR=.deps depmode=none /bin/sh ./depcomp \
        /bin/sh ./libtool --tag=CXX   --mode=compile  -DHAVE_CONFIG_H -I.   -I/usr/kerberos/include   -c -o pcrecpp.lo pcrecpp.cc
libtool: ignoring unknown tag CXX
libtool: unrecognized option `-DHAVE_CONFIG_H'
Try `libtool --help' for more information.
make[1]: *** [pcrecpp.lo] Error 1
make[1]: Leaving directory `/usr/local/directadmin/custombuild/pcre-7.8'
make: *** [all] Error 2
 

r0kawa

Verified User
Joined
Nov 17, 2005
Messages
17
after looking arround. I've got the solution.

Code:
yum install gcc-c++
PCRE needed c++ compiler from gcc
 
Top