CXS install problem

realitsolution

Verified User
Joined
Jul 1, 2019
Messages
62
Location
GMT +6.00
Checking Perl modules...
Can't locate Linux/Inotify2.pm in @INC (@INC contains: /etc/cxs /usr/local/lib64 /perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vend or_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 56) line 2.
BEGIN failed--compilation aborted at (eval 56) line 2.


when i am trying to install CXS showing this error.how i can solve it?
 

realitsolution

Verified User
Joined
Jul 1, 2019
Messages
62
Location
GMT +6.00
install complee

Error ClamAV socket [/path/to/socket] not found
You must install ClamAV (Clamavconnector on cPanel) or ensure clamd is running to use this product correctly

If the clamd socket is not automatically detected, and to clear this message, you must set clamdsock=/path/to/socket in /etc/cxs/cxs.defaults to the live socket location
 

pkwebhost

Verified User
Joined
Jul 2, 2019
Messages
36
Checking Perl modules...
Can't locate Linux/Inotify2.pm in @INC (@INC contains: /etc/cxs /usr/local/lib64 /perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vend or_perl /usr/lib64/perl5 /usr/share/perl5 .) at (eval 56) line 2.
BEGIN failed--compilation aborted at (eval 56) line 2.


when i am trying to install CXS showing this error.how i can solve it?
HTML:
# RedHat related OS's:

yum install dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

yum install perl-libwww-perl.noarch perl-LWP-Protocol-https.noarch perl-Archive-Tar.noarch perl-Archive-Zip.noarch perl-Linux-Inotify2 perl-Compress-Zlib sqlite perl-DBI perl-DBD-SQLite

# For Debian related OS's:
apt-get install libcompress-raw-zlib-perl libarchive-tar-wrapper-perl libarchive-zip-perl libwww-perl liblwp-protocol-https-perl liblinux-inotify2-perl libcgi-pm-perl sqlite3 libdbi-perl libdbd-sqlite3-perl
 

pkwebhost

Verified User
Joined
Jul 2, 2019
Messages
36
Same here, for Inotify2 I had to install the EPEL repo
Use these command to fix this issue

# RedHat related OS's:
yum install dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

yum install perl-libwww-perl.noarch perl-LWP-Protocol-https.noarch perl-Archive-Tar.noarch perl-Archive-Zip.noarch perl-Linux-Inotify2 perl-Compress-Zlib sqlite perl-DBI perl-DBD-SQLite
# For Debian related OS's:
apt-get install libcompress-raw-zlib-perl libarchive-tar-wrapper-perl libarchive-zip-perl libwww-perl liblwp-protocol-https-perl liblinux-inotify2-perl libcgi-pm-perl sqlite3 libdbi-perl libdbd-sqlite3-perl
 

pkwebhost

Verified User
Joined
Jul 2, 2019
Messages
36
install complee

Error ClamAV socket [/path/to/socket] not found
You must install ClamAV (Clamavconnector on cPanel) or ensure clamd is running to use this product correctly

If the clamd socket is not automatically detected, and to clear this message, you must set clamdsock=/path/to/socket in /etc/cxs/cxs.defaults to the live socket location
ClamAV scanning requires a running clamd daemon. By default cxs will look
for the clamd socket in common locations, if it is located elsewhere then
you must use the --clamdsock option and pass the socket location in every
cxs call (i.e. in cxscgi.sh and cxswatch.sh and the cxs CLI) or
use a cxs.defaults file

The clamd process must run as root and create a unix socket. To do this,
edit /etc/clamd.conf and set:

User root
LocalSocket /tmp/clamd.socket

Then restart clamd.
 

apogee

Verified User
Joined
Jul 6, 2019
Messages
44
Location
Europe
The clamd process must run as root and create a unix socket. To do this,
edit /etc/clamd.conf and set:

User root
LocalSocket /tmp/clamd.socket

Then restart clamd.
This is not necessary, just do this:
Code:
echo clamdsock=/run/clamd.socket >> /etc/cxs/cxs.defaults
 
Top