DA/Apache ignoring user's SSL certificate

Protected

Verified User
Joined
Oct 29, 2006
Messages
57
Hey all. I just moved to a new server and nearly everything seems fine, but when I tried to set up Let's Encrypt SSL for a user's domain name the results were odd.

The Let's Encrypt check was successful. DA shows the (apparently correct) certificate and key information in the SSL page of the control panel. It says Let's Encrypt is in use, renewal in 59 days, shows the list of subdomains I asked for. The CA certificate is set.

Everything is also correct in /usr/local/directadmin/data/users/USERNAME/domains , including ownership and permissions.

But when I try to access the user's website using https, the server's default certificate is being used, resulting in scary web browser errors. There are no error messages in the apache logs.

Services have been restarted and caches cleared, to no avail. I have tried accessing the website on both Firefox and Chrome. When I installed the server's default certificate, also Let's Encrypt, everything worked fine (the error in the web browser when accessing the user's website changed from self-signed certificate to invalid name in certificate - SERVERHOSTNAME). Any other ideas?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

If SSL is disabled for a domain, the script letsencrypt.sh does not enabled it, the script only issues certs. You'd better use Directadmin interface for it.
 
Top