debconf: unable to initialize frontend: Dialog

Strator

Verified User
Joined
Jan 19, 2011
Messages
297
For a few months now, every time I run "yum update" on my Almalinux server, the update ends with various debconf errors:

debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based frontend cannot be used. at /usr/share/perl5/vendor_perl/Debconf/FrontEnd/Dialog.pm line 79.)
debconf: falling back to frontend: Readline
Scanning processes...
Scanning candidates...

Restarting services...
Daemons using outdated libraries
--------------------------------


1. clamav-freshclam.service 5. directadmin.service 9. httpd.service 13. php-fpm80.service 17. spamassassin.service
2. [email protected] 6. dovecot.service 10. lfd.service 14. php-fpm83.service 18. sshd.service
3. console-getty.service 7. exim.service 11. mysqld.service 15. pure-certd.service 19. systemd-logind.service
4. dbus-broker.service 8. [email protected] 12. nginx.service 16. pure-ftpd.service 20. none of the above

(Enter the items or ranges you want to select, separated by spaces.)

Which services should be restarted?

Kinda hoped this would be a glitch that would go away through a following update, but since it didn't, I finally did the forensics today. It appears that debconf was installed on my system with DA 1.702, or more specifically, with the integration of needrestart.

68 | --quiet --assumeyes install needrestart | 2026-06-29 12:24 | Install

Which then proceeded to install the following packages:

perl-Text-WrapI18N-0.06-41.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
perl-Text-Iconv-1.7-43.el9.x86_64 Mon 29 Jun 2026 12:24:28 PM BST
perl-Text-CharWidth-0.04-44.el9.x86_64 Mon 29 Jun 2026 12:24:28 PM BST
perl-Sort-Naturally-1.03-29.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
perl-Proc-ProcessTable-0.634-1.el9.x86_64 Mon 29 Jun 2026 12:24:28 PM BST
perl-Module-Find-0.15-2.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
perl-Locale-gettext-1.07-21.el9.x86_64 Mon 29 Jun 2026 12:24:28 PM BST
perl-List-MoreUtils-XS-0.430-5.el9.x86_64 Mon 29 Jun 2026 12:24:28 PM BST
perl-List-MoreUtils-0.430-4.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
perl-libintl-perl-1.32-4.el9.x86_64 Mon 29 Jun 2026 12:24:28 PM BST
perl-File-ShareDir-1.118-4.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
perl-Exporter-Tiny-1.002002-6.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
perl-Class-Inspector-1.36-7.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
needrestart-3.8-1.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST
debconf-1.5.91-1.el9.noarch Mon 29 Jun 2026 12:24:28 PM BST

I don't think that debconf, which came from the epel repository, should be on my non-Debian system, and the errors above seem to confirm that. Which bears two question: Why was it installed anyway, and more importantly, how can I get rid of it in a way that it doesn't return with the next update? Thank you.
 
So from experience, if there is no reply to a post like this, it typically means people think I'm barking up the wrong tree. :ROFLMAO:

For what it's worth, our new AI masters assume the issue stems from an integration and packaging oversight between DirectAdmin's developers and the EPEL repository maintainers. That is because needrestart was originally authored for the Debian/Ubuntu ecosystem, where it heavitly relies on debconf to manage user prompts and configuration interfaces.

DirectAdmin / CustomBuild Developers: Responsible for enforcing the installation of needrestart on all systems without safely trapping or neutralizing Debian-centric behaviors (thereby inadvertently introducing the annoying debconf: unable to initialize frontend: Dialog warning onto RHEL-family systems).

EPEL Package Maintainers: Responsible, as a package hosted in EPEL for AlmaLinux/Rocky Linux should ideally have its debconf dependencies completely stripped, heavily mocked, or configured to run fully non-interactive out of the box, as debconf has no native business handling package configurations on a Red Hat derivative.

Me: Not responsible.

The suggested DIY solution is to force the environment to run headlessly, by adding DEBIAN_FRONTEND=noninteractive to the environment, or by manually adjusting the /etc/needrestart/needrestart.conf file to change how UI alerts are handled on the server.
 
Back
Top