debian 10 alpha testing

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
It seems that the problem that causes errors like chown: invalid user: ‘diradmin:diradmin’ is caused Debian 10 now handles paths.

The fix seems to be to execute command:

su -

before installation.

After that I managed to install DA on Debian 10.1

However I got this at the end of installation:
"Got signal 13 during installation!"

and the install script did not exit and I had to use ctrl-c to get back to shell.


https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918754
So you not install directadmin in a clean debian installation but in customized installation? Because if you need su seems the installation is not the default as the directadmin require.
I recommended to do just the default debian 10 installation and then install directadmin. They work fine.
 

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
Continued after 20 minutes:


--2019-09-13 21:45:15-- https://www.directadmin.com/cgi-bin/daupdate?uid=xxxxx&lid=xxxx&redirect=ok
Resolving www.directadmin.com (www.directadmin.com)... 216.144.255.179
Connecting to www.directadmin.com (www.directadmin.com)|216.144.255.179|:443... connected.
HTTP request sent, awaiting response...
HTTP/1.1 302 Found
Date: Fri, 13 Sep 2019 18:45:15 GMT
Server: Apache/2
x-return-code: redirect
Connection: close
x-md5: 79553dd232153ee9ab7f7d1a26873007
Location: http://69.162.69.58/stable_releases_26487463753/packed_debian100_64.tar.gz
Content-Length: 330
Content-Type: text/html; charset=iso-8859-1
Location: http://69.162.69.58/stable_releases_26487463753/packed_debian100_64.tar.gz [following]
--2019-09-13 21:45:15-- http://69.162.69.58/stable_releases_26487463753/packed_debian100_64.tar.gz
Connecting to 69.162.69.58:80... connected.
HTTP request sent, awaiting response...
HTTP/1.1 200 OK
Date: Fri, 13 Sep 2019 18:45:16 GMT
Server: Apache/2
Last-Modified: Wed, 28 Aug 2019 00:17:33 GMT
ETag: "89b1c3-5912250bc8140"
Accept-Ranges: bytes
Content-Length: 9023939
Vary: User-Agent
Keep-Alive: timeout=2, max=100
Connection: Keep-Alive
Content-Type: application/x-gzip
Content-Encoding: x-gzip
Length: 9023939 (8.6M) [application/x-gzip]
Saving to: ‘/usr/local/directadmin/update.tar.gz’

/usr/local/directadmin/update.tar.gz 33%[=========================> ] 2.86M --.-KB/s in 3m 7s

2019-09-13 21:48:23 (15.7 KB/s) - Read error at byte 2995589/9023939 (Connection timed out). Retrying.

--2019-09-13 21:48:24-- (try: 2) http://69.162.69.58/stable_releases_26487463753/packed_debian100_64.tar.gz
Connecting to 69.162.69.58:80... connected.
HTTP request sent, awaiting response...
HTTP/1.1 206 Partial Content
Date: Fri, 13 Sep 2019 18:48:24 GMT
Server: Apache/2
Last-Modified: Wed, 28 Aug 2019 00:17:33 GMT
ETag: "89b1c3-5912250bc8140"
Accept-Ranges: bytes
Content-Length: 6028350
Vary: User-Agent
Content-Range: bytes 2995589-9023938/9023939
Keep-Alive: timeout=2, max=100
Connection: Keep-Alive
Content-Type: application/x-gzip
Content-Encoding: x-gzip
Length: 9023939 (8.6M), 6028350 (5.7M) remaining [application/x-gzip]
Saving to: ‘/usr/local/directadmin/update.tar.gz’

/usr/local/directadmin/update.tar.gz 47%[++++++++++++++++++++++++++==========>
Seems you have network problems with the connection to to some directadmin servers
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
169
No, its clean: nothing else but the ssh and standard system utilities (or what ever it was called on the istallation screen).

blueice, did you log in as root before DA installation?
 
Last edited:

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
No, its clean: nothing else but the ssh and standard system utilities (or what ever it was called on the istallation screen).
why you need su? I never have do this and i have setup many many servers with debian 6,7,8,9,10 and directadmin.
This is test server? If yes can you give me access so i can find what is wrong?
 

tarta

Verified User
Joined
Jan 31, 2018
Messages
27
is it safe to say that I can now upgrade deb 9 to 10 and then rerun DirectAdmin upgrade following

cd /usr/local/directadmin/custombuild
./build clean
./build update
./build versions


?
 

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
is it safe to say that I can now upgrade deb 9 to 10 and then rerun DirectAdmin upgrade following

cd /usr/local/directadmin/custombuild
./build clean
./build update
./build versions


?
the directadmin for debian 10 is beta.
If you are interest for a upgrade path then you can test it and report any problems you have.
I not have any interest for a upgrade path (always i prefer clean install for better stability) so i can't tell you something.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,927
Hello,

For any Debian 10 issues, please report it here:
https://forum.directadmin.com/forumdisplay.php?f=99

I'll move this thread over.

Not too sure of the network slowdown with 69.162.69.58, but as it happens, we've swapped out that box with one in a different datacenter a few days ago.
It should be giving you a random IP anyway, so I'd say try the install again and see how it goes.

If you're getting stuck on the update.tar.gz download, and does the same thing from one of the other IPs, then it's most likely some sort of network slowdown.. hard to confirm.
You could create a ticket with the info, and we could take a look at that, at a minimum to rule out anything with the installer/servers, etc..

John
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
169
blueice, so how do you proceed after the clean OS install:

Do you log in as non-root user first?

And then do you log in as root and perform the DA download and execute ./setup.sh or what exactly is your procedure step by step on Debian 10?
 
Last edited:

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
blueice, so how do you proceed after the clean OS install:

Do you log in as non-root user first?

And then do you log in as root and perform the DA download and execute ./setup.sh or what exactly is your procedure step by step on Debian 10?
No i not have login with su.
I have login direct to root with certificate.
So i recommended to enable certificates and login direct as root or edit the file /etc/ssh/sshd_config and include the line:
PermitRootLogin yes

then restart the ssh and login direct as root.

Please do one of the above and let me know if all is ok. Possible this is the reason.
Thank you
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
169
Never used certificate for login before.

I now have the key pair. On Debian, where should I put the public key and what else I have to configure on sshd_config or elsewhere?
 
Last edited:

jet1972

Verified User
Joined
Jul 8, 2011
Messages
169
Again having the issue on Debian 10:

Letting CustomBuild manage SquirrelMail.
--2019-09-29 15:05:38-- http://files.directadmin.com/services/all/roundcube.sh
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 185.42.221.168, 104.128.54.74
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7536 (7.4K) [text/plain]
Saving to: ‘/usr/local/directadmin/scripts/roundcube.sh’

/usr/local/directadmin/scripts/roundcube.sh 100%[==================================================================================

2019-09-29 15:05:38 (791 KB/s) - ‘/usr/local/directadmin/scripts/roundcube.sh’ saved [7536/7536]

--2019-09-29 15:05:38-- http://files.directadmin.com/services/all/roundcube/roundcubemail-0.8.6.tar.gz
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 185.42.221.168, 104.128.54.74
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3786646 (3.6M) [application/x-gzip]
Saving to: ‘/usr/local/directadmin/scripts/packages/roundcubemail-0.8.6.tar.gz

packages/roundcubemail-0.8.6.tar.gz 22%[=======================> ] 912.18K --.-- KB/s eta 52m 28s
 
Last edited:

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
Again having the issue on Debian 10:

Letting CustomBuild manage SquirrelMail.
--2019-09-29 15:05:38-- http://files.directadmin.com/services/all/roundcube.sh
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 185.42.221.168, 104.128.54.74
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7536 (7.4K) [text/plain]
Saving to: ‘/usr/local/directadmin/scripts/roundcube.sh’

/usr/local/directadmin/scripts/roundcube.sh 100%[==================================================================================

2019-09-29 15:05:38 (791 KB/s) - ‘/usr/local/directadmin/scripts/roundcube.sh’ saved [7536/7536]

--2019-09-29 15:05:38-- http://files.directadmin.com/services/all/roundcube/roundcubemail-0.8.6.tar.gz
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 185.42.221.168, 104.128.54.74
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3786646 (3.6M) [application/x-gzip]
Saving to: ‘/usr/local/directadmin/scripts/packages/roundcubemail-0.8.6.tar.gz

packages/roundcubemail-0.8.6.tar.gz 22%[=======================> ] 912.18K --.-- KB/s eta 52m 28s
Seems that the problem problem is not related with debian 10 but with your network connection to directadmin servers. As i have see and in the past you have this. So i recommended one of the follow solutions:
- To try to use another mirror
- to check with the network provider if they have any network problem.

Also it is good to separate network problems and write it in another thread because it is not related with debian 10.
Thank you
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
169
Hello,

Run the "./build set_fastest" command to find the fastest mirror to you:
https://help.directadmin.com/item.php?id=305

John
Hello.

Done that (or the script does it with the auto option)

Now it happened again:

Synchronizing state of exim.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable exim
Created symlink /etc/systemd/system/multi-user.target.wants/exim.service → /etc/systemd/system/exim. service.
/usr/local/directadmin/scripts/exim.sh: line 134: chkconfig: command not found
Testing that exim is running correctly:
/usr/sbin/exim: error while loading shared libraries: libpcre.so.1: cannot open shared object file: No such file or directory
Exim seems to be broken with return code 127. Telling CB to compile exim.

********************************************************
Exim is broken, but we cannot find /custombuild/options.conf to set exim=yes. Do this later to com pile exim.
********************************************************

Letting CustomBuild manage SquirrelMail.
--2019-09-30 21:36:23-- http://files.directadmin.com/services/all/roundcube.sh
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 104.128.54.74, 185.42.221.1 68
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 7536 (7.4K) [text/plain]
Saving to: ‘/usr/local/directadmin/scripts/roundcube.sh’

/usr/local/directadmin/s 100%[==================================>] 7.36K --.-KB/s in 0.009s

2019-09-30 21:36:24 (792 KB/s) - ‘/usr/local/directadmin/scripts/roundcube.sh’ saved [7536/7536]

--2019-09-30 21:36:24-- http://files.directadmin.com/services/all/roundcube/roundcubemail-0.8.6.tar .gz
Resolving files.directadmin.com (files.directadmin.com)... 69.162.69.58, 104.128.54.74, 185.42.221.1 68
Connecting to files.directadmin.com (files.directadmin.com)|69.162.69.58|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3786646 (3.6M) [application/x-gzip]
Saving to: ‘/usr/local/directadmin/scripts/packages/roundcubemail-0.8.6.tar.gz

usr/local/directadmin/scripts/p 67%[==================================> ] 2.45M --.-KB/s eta 33m 36s
 
Last edited:

blueice

Verified User
Joined
Jan 18, 2004
Messages
191
you have check with your datacenter if the network have problems?
I have do many upgrades today in directadmin servers without problems.
Also you can manually select another mirror, You can see the instructions here:

https://help.directadmin.com/item.php?id=305

Also i suggest you again to open another posts for problems not related to debian 10 so we can keep this thread clean.
Thank you
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
169
The loading did continue eventually..

And I did the install with cert root log-in thru ssh and it seems to be installed about correctly.

There were few oddities:

That signal 13 again:

"file ./data/admin/packages.list created
ip.list written successfully
./data/admin/login.hist written successfully
./data/admin/next_ticket.number written correctly
./data/admin/services.status written successfully
tickets.list written successfully
Got signal 13 during install!
Admin user created"


And the install script did not return, had to use ctrl-c
 

ZipperZapper

Verified User
Joined
Nov 30, 2015
Messages
109
Is there any roadmap on this?
I'm currently using Ubuntu 14.04 LTS on my server, which is based on Debian 7 and now EOL. I also can't update Directadmin anymore, because 1.59 removed Debian 7 support and will break everything.

I kept using Ubuntu 14.04 untill now (it EOL'ed end of Q1 this year) because I wanted to jump to 18.04 LTS, so I could enjoy it for a few years to come. But Ubuntu 18.04 LTS is based on Debian 10 and support is still in alpha.

Can we expect support to be finalised in a few weeks, or should I just give up the wait and go for Ubuntu 16.04 LTS?
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,927
It's been BETA for a while, and we're just looking for any last bits before labeling it stable.
We don't currently know of any specific issues with it, so you might be fine to just start using it (take that with a grain of salt).

John
 

ZipperZapper

Verified User
Joined
Nov 30, 2015
Messages
109
It doesn't seem to work on Ubuntu 18.04.
I had my hoster set my License to Debian 10 BETA and installed a fresh copy of Ubuntu 18.04.

After using ./setup.sh auto all seemed fine and I could login to Directadmin at IP:2222. But the message center showed PHP was down.

PHP throws te following error:

Code:
systemd[1]: Starting The PHP FastCGI Process Manager...
php-fpm73[1659]: /usr/local/php73/sbin/php-fpm73: error while loading shared libraries: libicudata.so.64: cannot open shared object file: No such file or directory
systemd[1]: php-fpm73.service: Main process exited, code=exited, status=127/n/a
systemd[1]: php-fpm73.service: Failed with result 'exit-code'.
systemd[1]: Failed to start The PHP FastCGI Process Manager.
After a reboot, DirectAdmin stopped working completely, throwing a connection refused on IP:2222. It turned out the service failed to start automaticly and had to be started by hand.
After that Directadmin does work, but both Custombuild and CSF don't show up in the menu's (enhanched theme). They do in the Plugin Manager however.

Is this because of PHP failing? In Evolution skin they both show up in the menu. CSF seems to work, CustomBuild only throws Network Error.

One other strange thing: Admin > Licensing / Updates shows "Compiled on: Debian 9.0 64-bit". Shouldn't that be Debian 10?
 
Last edited:
Top