Did anyone notice a weird character in the latest exim.variables.conf file ?

maxi32

Verified User
Joined
Jul 25, 2016
Messages
51
Location
Malaysia
When I look at exim.variables.conf, I can see the folloing equal character '='. May I know what is the purpose of this equal character ?

weird-character-in-exim-conf.JPG

When I build exim_conf, I got the following error, which definitely related to the weird '=' sign.

error-build.JPG
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,392
Location
Maastricht
Nope, that = character shouldn't be in there.
Looke like this on my servers:
Code:
2020-02-13 00:37:35 (543 KB/s) - '/etc/exim.pl.cb20' saved [18743/18743]

Enabling BlockCracking...
BlockCracking is now enabled.
2020-02-13 00:37:35 cwd=/usr/local/directadmin/custombuild 2 args: /usr/sbin/exim --version
2020-02-13 00:37:35 cwd=/usr/local/directadmin/custombuild 2 args: /usr/sbin/exim --version
Enabling Easy Spam Fighter...
Easy Spam Fighter is now enabled.
Restarting exim.
Maybe you can use another mirror and try again?
 

maxi32

Verified User
Joined
Jul 25, 2016
Messages
51
Location
Malaysia
What is your current mirror? I have no luck getting rid of that character. I tried few mirrors example files2.directadmin.com, files28.directadmin.com directadmin.mirror.liteserver.nl still no luck.

Things I did:
1) rebuild exim.
2) rebuild exim_conf
3) restore da permission from here: https://help.directadmin.com/item.php?id=173

even if I remove the character manually, it still got overwritten by the exim_conf build command.
What do you think could be wrong here.

BTW I dont have a file called
/etc/exim.variables.conf.custom

So I don't think it's coming from here.
 

maxi32

Verified User
Joined
Jul 25, 2016
Messages
51
Location
Malaysia
Ok, I can reproduce this error:

When I set ssl_configuration=modern, and try to rebuild exim_conf, I got that weird character. I set it back to immediate and the problem is gone.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,392
Location
Maastricht
When I set ssl_configuration=modern, and try to rebuild exim_conf, I got that weird character.
Thank you. I use several mirrors, but I don't use that setting yet in my directadmin.conf so my servers would use the default setting.
Nice you discovered this issue!
 
Top