Direct Admin Crashes

JoeInShed

Verified User
Joined
Nov 14, 2003
Messages
28
Direct Admin itself keeps falling over, the server, apache, bind, everything else is fine, just directadmin.

It all seemed to start with this:
2003:12:02-20:21:05: *** Program Update: Request for License update: 216.194.67.119
2003:12:02-20:22:21: Update of software successfull!
2003:12:02-20:22:21: signal TERM received. Waiting for children to exit
2003:12:02-20:22:21: Clean shutdown successful
2003:12:02-20:22:21: directadmin restarted
2003:12:02-20:22:21: directadmin started
2003:12:02-20:22:24: directadmin restarted
2003:12:02-20:23:01: directadmin started
2003:12:02-20:23:04: directadmin restarted
2003:12:02-20:24:00: directadmin started
2003:12:02-20:24:04: directadmin restarted
here's what happens when we try to start directadmin, this also happens on boot...
[root@srv directadmin]# service directadmin start
Starting DirectAdmin: [ OK ]
[root@srv directadmin]# service directadmin stop
Stopping DirectAdmin: [FAILED]
[root@srv directadmin]# service directadmin status
directadmin is stopped
[root@srv directadmin]# service directadmin start
Starting DirectAdmin: [ OK ]
[root@srv directadmin]# service directadmin status
directadmin dead but pid file exists
On starting DA, the pid file
Code:
/var/run/directadmin.pid
does get a PID written to it.

Its starting then falling over straight away. It seems this started upon auto license check ? but might just be coincidence.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

Try this:
Code:
cd /usr/local/directadmin
./directadmin
If you get a segmentation fault or a bus error, that means that you've selected the wrong OS in your license file. Double check that it's correct. Also, the error should be outputted if it doesn't work.

John
 

JoeInShed

Verified User
Joined
Nov 14, 2003
Messages
28
error loading certificate key

is this referring to an SSL certificate (which I had a go at setting up, and seemed to work fine), or the license certificate (which hasnt been changed). The server hasnt been put to proper use yet, we've just been going through testing the different da features, no changes like skinning or anything have been made so it should be fine.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Check the permissions on the file. Make sure it's owned by diradmin:diradmin and is readable.

John
 

JoeInShed

Verified User
Joined
Nov 14, 2003
Messages
28
-rw-r--r-- 1 diradmin diradmin 1452 Nov 26 23:33 cacert.pem
-rw-r--r-- 1 diradmin diradmin 963 Nov 26 23:33 cakey.pem.tmp
-rw------- 1 diradmin diradmin 1492 Nov 26 22:32 directadmin.conf
-rw-r--r-- 1 diradmin diradmin 1298 Nov 26 22:07 license.key
-r-------- 1 diradmin diradmin 30 Nov 26 22:08 mysql.conf
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Alright, then you'll need to check the path in the directadmin.conf (in that directory). If everything seems alright, then something is up with the certificates (Or else I'd need to have a look).

John
 

JoeInShed

Verified User
Joined
Nov 14, 2003
Messages
28
I hashed out the cert stuff from the conf file (ssl=0 plus 2 more lines), now it works. must be the ssl keys. will look into it.
 
Top