DirectAdmin isn't working anymore

kanary

Verified User
Joined
Jun 8, 2007
Messages
113
Location
Holland - Het westland
Hi,

As main problem i had that the directadmin dataskq wasn't running every minute so i was using google to try to fix it nothing worked and someone suggested that i need to do directadmin -i

After that my password reseted and apache stopped running to fixed this an let httpd start again i had to use ./build rewite_conf (custombuild) now i my email adresses aren't working anymore and when i run dataskq d1200 i get this message:

Debug mode. Level 1200

root priv set: uid:0 gid:0 euid:0 egid:0
pidfile written
staring queue

The top request got:
8710 root 20 0 76192 37m 2340 R 99 0.9 46:22.95 dataskq

when i do an strace on this process i only get this
Process 8710 attached - interrupt to quit
read(3, "0.38.19.226.ded.telnor.net, but "..., 4096) = 4096
gettimeofday({1360786453, 58051}, NULL) = 0
gettimeofday({1360786453, 58512}, NULL) = 0
gettimeofday({1360786453, 167786}, NULL) = 0
gettimeofday({1360786453, 169111}, NULL) = 0
gettimeofday({1360786453, 283757}, NULL) = 0
gettimeofday({1360786453, 283919}, NULL) = 0
gettimeofday({1360786453, 388041}, NULL) = 0
gettimeofday({1360786453, 388267}, NULL) = 0
gettimeofday({1360786453, 527583}, NULL) = 0
gettimeofday({1360786453, 527746}, NULL) = 0
gettimeofday({1360786453, 709559}, NULL) = 0
gettimeofday({1360786453, 709689}, NULL) = 0
gettimeofday({1360786453, 821766}, NULL) = 0
gettimeofday({1360786453, 821898}, NULL) = 0
gettimeofday({1360786453, 930092}, NULL) = 0
gettimeofday({1360786453, 930299}, NULL) = 0
gettimeofday({1360786454, 42597}, NULL) = 0
gettimeofday({1360786454, 42961}, NULL) = 0
read(3, "POSSIBLE BREAK-IN ATTEMPT!\nDec 2"..., 4096) = 4096
gettimeofday({1360786454, 148276}, NULL) = 0
gettimeofday({1360786454, 148403}, NULL) = 0
gettimeofday({1360786454, 288344}, NULL) = 0
gettimeofday({1360786454, 288481}, NULL) = 0
gettimeofday({1360786454, 391742}, NULL) = 0
gettimeofday({1360786454, 392110}, NULL) = 0
gettimeofday({1360786454, 494074}, NULL) = 0
gettimeofday({1360786454, 494206}, NULL) = 0
gettimeofday({1360786454, 605316}, NULL) = 0
gettimeofday({1360786454, 605445}, NULL) = 0
gettimeofday({1360786454, 716226}, NULL) = 0
gettimeofday({1360786454, 716355}, NULL) = 0


does anyone knows how to fix this ?

Thanks for any help
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,818
Location
GMT +7.00
Hello

You should never run

Code:
# /usr/local/directadmin/directadmin i
on a live server, unless you 100% sure you need it. As it will reset the directadmin.conf to the default state, and rewrite some system configs, and change admin, da_admin passwords. And might break some other things on the server.

and what do you see with

Code:
/usr/local/directadmin/data/task.queue
?

This seems to me as if dataskq scans logs for brute force attack, and to avoid overloading your server (as well as others), it pauses before a next loop. So that's OK, I'd rather say.

when i do an strace on this process i only get this
Process 8710 attached - interrupt to quit
 

kanary

Verified User
Joined
Jun 8, 2007
Messages
113
Location
Holland - Het westland
strace is going to get you no where...try http://help.directadmin.com/item.php?id=293
Thanks for the tip.

Directadmin seems to run normal.

after the directadmin -i the directadmin.conf was reseted and the bruteforce option was on i have manuly set it off and then directadmin worked again but now i got the next problem

when i open the email account page of directadmin i now get after the directadmin -i
Cannot open the user password file for reading

how can i fix this ?
 

kanary

Verified User
Joined
Jun 8, 2007
Messages
113
Location
Holland - Het westland
Hello

You should never run

Code:
# /usr/local/directadmin/directadmin i
on a live server, unless you 100% sure you need it. As it will reset the directadmin.conf to the default state, and rewrite some system configs, and change admin, da_admin passwords. And might break some other things on the server.

and what do you see with

Code:
/usr/local/directadmin/data/task.queue
?

This seems to me as if dataskq scans logs for brute force attack, and to avoid overloading your server (as well as others), it pauses before a next loop. So that's OK, I'd rather say.

on a forum they said you need to do that but like you said it only broke more then fixed it.
I disabled the brute force log but now my emails arent working when i open an mail account page i get the following:
Cannot open the user password file for reading
 

chatwizrd

Verified User
Joined
Jul 3, 2005
Messages
2,007
Hopefully you have backups... My guess is /etc/virtual has been totally reset and you lost all your settings.
 

chatwizrd

Verified User
Joined
Jul 3, 2005
Messages
2,007
i thought so to but everything seems to be there even that passwd files in the domain folders
The password files for emails are in /etc/virtual. There is nothing in /usr/local/directadmin or the users home file for the passwords. Directadmin accounts are authenticated off of the OS password file.
 
Top