Directadmin starting only every now and then on boot

jet1972

Verified User
Joined
Jul 8, 2011
Messages
194
Having issue with DA on Debian 10:

Got this output with: systemctl status directadmin.service

● directadmin.service - DirectAdmin Web Control Panel
Loaded: loaded (/etc/systemd/system/directadmin.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Fri 2020-01-10 12:55:15 EET; 5min ago
Docs: http://www.directadmin.com
Process: 457 ExecStart=/usr/local/directadmin/directadmin d (code=exited, status=0/SUCCESS)

Jan 10 12:53:42 srv10.dom.fi systemd[1]: Starting DirectAdmin Web Control Panel...
Jan 10 12:53:42 srv10.dom.fi systemd[1]: directadmin.service: Can't open PID file /run/directadmin.pid (yet?) after start: No such file or directory
Jan 10 12:55:12 srv10.dom.fi systemd[1]: directadmin.service: Start operation timed out. Terminating.
Jan 10 12:55:15 srv10.dom.fi systemd[1]: directadmin.service: Failed with result 'timeout'.
Jan 10 12:55:15 srv10.dom.fi systemd[1]: Failed to start DirectAdmin Web Control Panel.
 

ZipperZapper

Verified User
Joined
Nov 30, 2015
Messages
111
Do you have a static IP? On Ubuntu 18.04 (Debian 10 based) DirectAdmin and PHP wouldn't start most of the time at boot, but would start by hand.

Setting a static IP fixed it for me.
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
194
Yes, I have a static IP and I can restart DirectAdmin manually and it runs OK but for some reson it will usually fail when run automatically at the startup.

Delaying DA starting may fix the issue, but how to delay DA execution on startup?
 

jet1972

Verified User
Joined
Jul 8, 2011
Messages
194
Any new suggestions?

I can access the server thru SSH so the connection is OK and server is up and running but DA is not starting reliably on startup even with the latest DA Version 1.601 !
 
Last edited:

jet1972

Verified User
Joined
Jul 8, 2011
Messages
194
Now with Debian v10.3 update and the latest v1.603 DA it seems now to work flawlessly and the issue that I had with Clam AV database update is also gone.
 
Last edited:
Top