DMARc SPF autoreply vacation message Gmail fails

ikkeben

Verified User
Joined
May 22, 2014
Messages
688
Location
Netherlands Germany
IF "100%"

DMARc, DKIM, SPF are used with p=reject.

Then Vacation message set in DA CP GUI replied to gmail adressed are rejected.

Unauthenticated email from thatdomain.tld is not accepted due to domain's\n550-5.7.1 DMARC policy. Please contact the administrator of domain if\n550-5.7.1 this was a legitimate mail. Please visit\n550-5.7.1 https://support.google.com/mail/answer/2451690

How to solve this while i know with forwarding it could be...
But this should not be a problem

hostname is mailhost and mailserver DKIM dns for that domain has then ofcourse DKIM from hostname.
Is in tests all 100%

So how to this?
http://arc-spec.org/

or even so https://www.spamresource.com/2015/12/mail-forwarding-in-dmarc-world.html

SRS hu???????? https://forum.directadmin.com/showthread.php?t=39066&p=195150#post195150

Some one solved this for ( domain and mail on DA box where hostname is mx mailserver for all domains) then using vacation message in Directadmin account.
Then someone sending from Gmail account, the autoreply is blocked by Gmail see above for message.

This should be working out of the BLUE in DA admin GUI with dmarc, spf, dkim set right reslust in tests ok only this...

Is long long a not solved problem?
As for issues with DKIM and SPF on servers with SRS enabled.... it was found out that DKIM might get corrupted due to SRS, and SPF might fail if you don't have SRS. So we have to options here:
Also can't find a HELP topic / docu for SRS related as /etc/exim.srs.conf and this one ? .include_if_exists /etc/exim.srs.forward.conf
 
Last edited:

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,265
Location
Maastricht
I got the same issues with forwarded mail. I get a report with a SPF fail when I send a mail to my customer and the customer has a forward to gmail. Because customers domain is not allowed to send mail in behalve of me ofcourse.

Same kind of issue.

It does not get into the spam, but there should be some solution.
 

ikkeben

Verified User
Joined
May 22, 2014
Messages
688
Location
Netherlands Germany
Don't know if the new exim.conf update 4.5.17 to 4.5.18 solved this?

Changes in
#EDIT#58: uservacation:
to = "${sender_address}"
to = "${reply_address}"

and
#COMMENT#59: userautoreply
to = "${sender_address}"
to = "${reply_address}"



the same
I don't have time to test

Can somone from DA support explain this?
?
 
Last edited:
Top