Email delivery problem

zebios

New member
Joined
Dec 3, 2019
Messages
6
Hello,

I have a headache trying to find a solution without any success

i'm using cloudflare nameservers for all my domains so i set up every single domain with the provided data in DNS Management section in DA..The problem i don't receive any email and even the email can't be sent..the port 25 is open and i think i have a problem with MX record

Here is the result


Can anyone help to seewhat's going on?
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
581
Location
Murfreesboro
I am guessing it this

MX records check
No MX records exist within the zone. This is legal, but if you want to receive E-mail on this domain, you should have MX record(s). The program can't continue in a case like this, so we are assuming you don't receive mail on this domain.
Notes

i set up every single domain with the provided data in DNS Management section in DA
You are not using DA for dns. You said you are using Cloudflare
i'm using cloudflare nameservers for all my domains
 

zebios

New member
Joined
Dec 3, 2019
Messages
6
I am guessing it this

MX records check
No MX records exist within the zone. This is legal, but if you want to receive E-mail on this domain, you should have MX record(s). The program can't continue in a case like this, so we are assuming you don't receive mail on this domain.
Notes



You are not using DA for dns. You said you are using Cloudflare
Thanks for your reply

Yes i'm using cloudflare but you have to put the informations given by DA to cloudflare so this is related. All the infos put on cloudflare are given by DA in DNS Management section, the nameservers are provided by cloudflare.

I used cpanel before jumping to DA and didn't ever hade this problem, so i don't really know what's going on with DA

I just want to use the local mail server!!!
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
581
Location
Murfreesboro
I dont use cloudflare.

maybe this https://help.directadmin.com/item.php?id=665

Could be the dont support DA yet?

 

zebios

New member
Joined
Dec 3, 2019
Messages
6
I don't think that it's a port related since my domain is already proxied through cloudflare and it's working just fine. The real problem is in the MX record..it's like cloudflare doesn't the read the mail server credentials provided by DA.

I really hope using cloudflare could help me on this
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
581
Location
Murfreesboro

MX
MX Records are necessary for delivery of email to a mail server. Any MX record Servername requires a corresponding A record that lists the IP address of the mail server.
To add an MX record:

1. Click Add Record.
2. Choose MX from the Type field to display the required MX record details:
adding_mx_records_annotated.png

Mail server is the DNS hostname of the mail server. Priority is a relative number.
The lowest Priority number in a group of MX records will have priority over the rest.

3. Click Save.
A typical MX record Name is the root domain such as example.com. However, reach out to your email hosting provider to confirm the MX Name and Server details.
(What is an MX record?)
 

zebios

New member
Joined
Dec 3, 2019
Messages
6
Thanks for your reply i appreciate it :)
Actually i know what an mx record is and how to set it..I think it's working fine..I contacted cloudflare and they confirm to me that there is no smtp service running on my vps!!!Is this possible??I thought DA install an smtp service no???

Network Tools  DNS IP Email.png
 

zebios

New member
Joined
Dec 3, 2019
Messages
6
What do you get with
Code:
systemctl status exim
I get this

Code:
 exim.service - Exim Mail Transport Agent
   Loaded: loaded (/etc/systemd/system/exim.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2019-12-03 17:24:07 PST; 16h ago
 Main PID: 18529 (exim)
   CGroup: /system.slice/exim.service
           └─18529 /usr/sbin/exim -bd -q1h

Dec 03 17:24:07 server.omrseo.com systemd[1]: Stopped Exim Mail Transport A....
Dec 03 17:24:07 server.omrseo.com systemd[1]: Started Exim Mail Transport A....
Hint: Some lines were ellipsized, use -l to show in full.
With this

Code:
exim -v
I get this :


Code:
LOG: MAIN
  cwd=/root 2 args: exim -v
Exim is a Mail Transfer Agent. It is normally called by Mail User Agents,
not directly from a shell command line. Options and/or arguments control
what it does when called. For a list of options, see the Exim documentation.
 

zebios

New member
Joined
Dec 3, 2019
Messages
6
Thanks for your pro activity man i appreciate it.

Problem solved..actually the ports were closed by my vps provider, i don't know why they blocked the mail ports!!!

I had also an rdns problem..theserver ip didn't solve to the hostname so i added it and it's all ok now.

But...yeah always there's a "but" thing lol...The ip is blacklisted by outlook even it passes all the blacklist tests..so i fiiled up the outlook form to get the ip whitelisted..i hope they will do it soon :(
 

ikkeben

Verified User
Joined
May 22, 2014
Messages
653
Location
Netherlands Germany
Thanks for your pro activity man i appreciate it.

Problem solved..actually the ports were closed by my vps provider, i don't know why they blocked the mail ports!!!

I had also an rdns problem..theserver ip didn't solve to the hostname so i added it and it's all ok now.

But...yeah always there's a "but" thing lol...The ip is blacklisted by outlook even it passes all the blacklist tests..so i fiiled up the outlook form to get the ip whitelisted..i hope they will do it soon :(
So take care of that blacklist part , if it is you having that ip longer then who knows maybe you provider has blocked ports because of that.
If you don't have that ip for your own , or before it was for someone els then als your provider more info's if they did know that ( abuse / black list) and so on.
 
Top