Error Build Apache

lrdmafia

Verified User
Joined
Jun 30, 2020
Messages
34
hello,
I tried to update roundcube to the latest version and since then it broke everything, I get this error,

[[email protected] ~]# service httpd status
httpd dead but pid file exists
[[email protected] ~]# service httpd stop
Stopping httpd: httpd: Syntax error on line 164 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf/extra/httpd-includes.conf: Syntax error on line 1 of /etc/httpd/conf/extra/mod_lsapi.conf: Cannot load /usr/lib/apache/mod_lsapi.so into server: /usr/lib/apache/mod_lsapi.so: cannot open shared object file: No such file or directory

I have centos 6.10 ,

cd /usr/local/directadmin/custombuild/
./build update
./build clean
./build apache

and I get this error:



Install the project...
-- Install configuration: ""
-- Installing: /usr/lib/apache/mod_hostinglimits.so
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
Package yum-utils-1.1.30-42.el6_10.noarch already installed and latest version
Package file-5.04-30.el6.x86_64 already installed and latest version
Nothing to do
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
No package alt-python37-lxml available.
Error: Nothing to do
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Match for argument liblsapi-1.1-57*
Nothing to download
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Match for argument liblsapi-1.1-57*
Nothing to download
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Match for argument liblsapi-1.1-57*
Nothing to download
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Match for argument liblsapi-1.1-57*
Nothing to download
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Match for argument liblsapi-1.1-57*
Nothing to download
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No Match for argument liblsapi-1.1-57*
Nothing to download
*** mod_lsapi.da_cb_install error: cannot download liblsapi 1.1-57 version ***
CMake Error: The source directory "/usr/local/directadmin/custombuild/mod_lsapi-1.1-57" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make: Nothing to be done for `install'.
Restarting apache.
Stopping httpd: httpd: Syntax error on line 164 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf/extra/httpd-includes.conf: Syntax error on line 1 of /etc/httpd/conf/extra/mod_lsapi.conf: Cannot load /usr/lib/apache/mod_lsapi.so into server: /usr/lib/apache/mod_lsapi.so: cannot open shared object file: No such file or directory

Starting httpd: httpd: Syntax error on line 164 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf/extra/httpd-includes.conf: Syntax error on line 1 of /etc/httpd/conf/extra/mod_lsapi.conf: Cannot load /usr/lib/apache/mod_lsapi.so into server: /usr/lib/apache/mod_lsapi.so: cannot open shared object file: No such file or directory


Could you please help me ?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
10,596
Location
LT, EU
mod_lsapi is a CloudLinux module, if they still support CloudLinux 6 - you may contact their support for assistance.
 

zwankie

Verified User
Joined
Apr 19, 2020
Messages
91
Have you tried this?

Also check your yum.conf file for an exclude on liblsapi*
 

zwankie

Verified User
Joined
Apr 19, 2020
Messages
91
When trying to install CloudLinux Mod LSAPI on AlmaLinux 8.x with DirectAdmin 1.645x and CL the following errors.
I also contacted CL support who had a look on the server but could not get it to work - CL suggested I direct this to DA.

custombuild]# ./build mod_lsapi

This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:18:40 ago on Sun Nov 27 06:49:51 2022.
Package yum-utils-4.0.21-14.1.el8.noarch is already installed.
Package file-5.33-21.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:18:43 ago on Sun Nov 27 06:49:51 2022.
Package alt-python37-lxml-4.4.2-5.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:18:47 ago on Sun Nov 27 06:49:51 2022.
Package criu-lve-3.13-6.el8.x86_64 is already installed.
Package criu-lve-devel-3.13-6.el8.x86_64 is already installed.
Package crit-lve-3.13-6.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:18:50 ago on Sun Nov 27 06:49:51 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:18:59 ago on Sun Nov 27 06:49:51 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:19:08 ago on Sun Nov 27 06:49:51 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:19:18 ago on Sun Nov 27 06:49:51 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:19:27 ago on Sun Nov 27 06:49:51 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:19:36 ago on Sun Nov 27 06:49:51 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
*** mod_lsapi.da_cb_install error: cannot download liblsapi 1.1-60 version ***
CMake Error: The source directory "/usr/local/directadmin/custombuild/mod_lsapi-1.1-60" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make: Nothing to be done for 'install'.
Job for httpd.service failed because the control process exited with error code.
See "systemctl status httpd.service" and "journalctl -xe" for details.


Even installing liblsapi and liblsapi-devel with you does not solve the problem because it installs liblsapi-1.1-61 but CustomBuild still does not complete the operation when trying ./build nginx_apache

The problem is when I run ./build nginx_apache there is another error:

This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:26:42 ago on Sun Nov 27 09:17:54 2022.
Package criu-lve-3.13-6.el8.x86_64 is already installed.
Package criu-lve-devel-3.13-6.el8.x86_64 is already installed.
Package crit-lve-3.13-6.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:26:46 ago on Sun Nov 27 09:17:54 2022.
No package liblsapi-1.1-60* available.
Exiting due to strict setting.
Error: No package liblsapi-1.1-60* available.
 
Last edited:

sahostking

Verified User
Joined
Jan 29, 2021
Messages
75
Location
South Africa
Alright seemed I figure it out. It occurs when its in the cloudlinux-testing repo still.

So ran the following first:

yum update liblsapi --enablerepo=cloudlinux-updates-testing

then only ran change over to apache.

cd /usr/local/directadmin/custombuild
./build update
./build set webserver apache
./build set php1_mode lsphp
./build set php2_mode lsphp
./build set php3_mode lsphp
./build set php4_mode lsphp
./build apache
./build php n
./build rewrite_confs

It still happened.

So had to edit /etc/yum.repos.d/cloudlinux.repo and set cloudlinux-updates-testing to enabled.

Retried and now all goes through well.
 
Last edited:
Top