Error build PHP 7.4

bibiugly

Verified User
Joined
Apr 9, 2019
Messages
9
When I build PHP7.4 I have a problem, pls help me.
Code:
checking whether to enable internationalization support... yes
checking for icu-uc >= 50.1 icu-io icu-i18n... no
configure: error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were not met:

Requested 'icu-uc >= 50.1' but version of icu-uc is 4.8.1.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ICU_CFLAGS
and ICU_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** There was an error while trying to configure php. Check the configure file
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,328
Location
LT, EU
Try:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build php n
 

nskins

New member
Joined
Dec 1, 2019
Messages
2
Try:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build php n
configure: error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were not met:
Requested 'icu-uc >= 50.1' but version of icu-uc is 4.8.1.1


I had the same problem as you
I tried several times as ad, but I still couldn't build php 7.4
 

dyna

New member
Joined
Dec 5, 2019
Messages
2
got the same problem.

configure: error: Package requirements (icu-uc >= 50.1 icu-io icu-i18n) were not met:

Requested 'icu-uc >= 50.1' but version of icu-uc is 4.8.1.1

What to do
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,328
Location
LT, EU
Do you have /usr/local/icu/include/unicode/uvernum.h on your system? If yes, "./build versions" should list an update available :)

To update ICU you may also do:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build icu
Or just click "Build" for ICU in CustomBuild plugin.
 
Top