[ERROR] cURL Error: Could not resolve host: n16

kang28ivan

Verified User
Joined
Mar 16, 2017
Messages
33
Hi,

I get the problem of not being able to sync on all of my directadmin servers with message error
[ERROR] cURL Error: Could not resolve host: n16@mydirectadminhostname.com
this happened to the module that I used, the developer told me that it was not a production error on the module
Unfortunately, we are not able to reproduce the cURL error you mentioned in our test environment. We suspect that the issue is related to your WHMCS or DirectAdmin settings.
I'm already confused looking for this problems because the curl on whmcs is the latest version and this happens after updating the version of Directadmin to 1.60.4, in the previous version there seems to be no problem

can anyone help solve this problem? maybe smtalk or zEitEr can help solve this problem

Thank you
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

The provided details does not give enough information. Since you've masked your domain name, it makes impossible to check how it resolves on our side.

So the only things which are possible to suggest:

- check /etc/resolv.conf on your server to make sure it's populated with valid nameservers IPs
- check how your domain resolves and make sure it's available outside your network
 

kang28ivan

Verified User
Joined
Mar 16, 2017
Messages
33
Hello,

The provided details does not give enough information. Since you've masked your domain name, it makes impossible to check how it resolves on our side.
Hello,

Sorry, I can't input hostname here
When I ping and tracert it is connected there are no problems
Code:
[root@master ~]# traceroute bugis.myhostname.com
traceroute to bugis.myhostname.com (45.64.96.265), 30 hops max, 60 byte packets
1  static-198-54-129-25.cust.tzulo.com (198.54.129.25)  0.875 ms  0.663 ms  0.605 ms
2  64.32.2.197 (64.32.2.197)  0.456 ms  2.007 ms  1.718 ms
3  * 10.0.0.5 (10.0.0.5)  1.436 ms 10.0.0.21 (10.0.0.21)  1.341 ms
4  hu0-13-0-4.ccr41.lax04.atlas.cogentco.com (38.142.237.209)  1.212 ms  1.119 ms  1.016 ms
5  be3360.ccr42.lax01.atlas.cogentco.com (154.54.25.149)  1.045 ms  0.985 ms  0.957 ms
6  be3243.ccr41.lax05.atlas.cogentco.com (154.54.27.118)  0.742 ms  0.934 ms  0.867 ms
7  tata.lax05.atlas.cogentco.com (154.54.11.194)  0.705 ms  0.673 ms  0.722 ms
8  if-ae-30-2.tcore1.lvw-los-angeles.as6453.net (206.82.129.19)  1.020 ms  2.378 ms  2.519 ms
9  63.243.197.2 (63.243.197.2)  0.798 ms  1.373 ms  1.208 ms
10  edge-1.v36.sg3.sg.gs (103.14.244.11)  164.098 ms  164.118 ms  164.077 ms
11  * * *
12  bugis.myhostname.com (45.64.96.265)  176.340 ms  176.375 ms  176.283 ms
So the only things which are possible to suggest:

- check /etc/resolv.conf on your server to make sure it's populated with valid nameservers IPs
- check how your domain resolves and make sure it's available outside your network
Yes its no problem,

Code:
 cat /etc/resolv.conf
# Generated by NetworkManager
search bugis.myhostname.com
nameserver 8.8.8.8
nameserver 8.8.4.4
nameserver 1.1.1.1
Another information, if using Login Keys its working not error with curl, but when with password its not working, I can't use Login Keys because can managed with the modules, I using modulesgarden wp manager
 
Top