Error in default options.conf CB 2.0

Jan_E

Verified User
Joined
Apr 29, 2011
Messages
121
Location
Amsterdam, NL, EU
I had some troubles with installing PHP 5.4 as suphp and discovered what was wrong: a typo in the generated default options.conf. I did the following:
Code:
cd /usr/local/directadmin
mv custombuild custombuild_1.x
wget -O custombuild.tar.gz http://files.directadmin.com/services/custombuild/2.0/custombuild.tar.gz
tar xvzf custombuild.tar.gz
cd custombuild
./build
After this, the options.conf began as follows:
Code:
#PHP settings.
Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, no. php1/php2_mode: mod_php, php-fpm or suphp)
php1_release=5.4
php2_release=no
php1_mode=mod_php
php2_mode=php-fpm
php_ini=no
#Possible values - production or development
php_ini_type=production
ioncube=no
zend=no
That should of course be with a # preceding the second line:
Code:
#PHP settings.
#Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, no. php1/php2_mode: mod_php, php-fpm or suphp)
php1_release=5.4
php2_release=no
#et cetera
The error prevented ./build to build suphp ...
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

Thanks for the report.
Looks like Martynas has fixed the code.
I've just updated it on files1.

John
 
Top