EXIM local relay mail

verkerkict

Verified User
Joined
Jan 19, 2007
Messages
12
Hello guys,

We use directadmin for a couple of years now, and use spamexperts as spamfiltering frontend.
We configured exim to check an list for domains that're active on the spamexperts servers:

domainlist spamexperts_domains = lsearch;/etc/virtual/spamexperts_domains

deny
domains = +spamexperts_domains
!hosts = delivery.antispamcloud.com : localhost
message = Please deliver mail to the address specified in the MX records for this domain.

So when there tries to deliver mail directly to the directadmin server it is blocked.

In this example we got 2 domains on the same server.
DomainA on serverA
DomainB on serverA

Both are using incoming and outgoing of ServerA
Domain A and B both are on the spamexperts_domains.
When someone of DomainA mails to DomainB is will go internaly but the mail is blocked because of the exim script.

Is there a to solve this?
I think there're 2 possible solutions,

1) relay internal mail externally by uncheck the option in Directadmin (mx records):
Use this server to handle my emails.
If not, change the MX record and uncheck this option

But I dont know of there is something else that will go wrong when i uncheck this option?


2)Or to change the above script to accept mail from local users, but i dont know how to do this.

Hope you can help.
Thank you!
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

Try and add:

Code:
!authenticated = *
into there, so it will be something like:

Code:
  deny
          !authenticated = *
          domains = +spamexperts_domains
          !hosts = delivery.antispamcloud.com : localhost
          message = Please deliver mail to the address specified in the MX records for this domain.
Please note, I did not test it on my end. But the idea should work. Let me know your results.

It's important in which ACL you add this check.
 
Top