Forwarding in /etc/hosts 'Apache is functioning normally '

Thommen

New member
Joined
Feb 22, 2021
Messages
14
I set up a domain name in DirectAdmin. Before domain delegation, I want to check how the website works.

In the / etc / hosts
I gave the IP and domain name. It redirects me to the message 'Apache is functioning normally' and not to the website directory.

I have the correct data data/users/admin/httpd.conf file set up. Where is the problem?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,924
Location
LT, EU
Make sure IP in /etc/hosts matches the one set in DirectAdmin for the domain/user.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,924
Location
LT, EU
Yes, but we don't know what IP is seen in user httpd.conf?

And yes, at this time I see:
% curl --resolve tom.tom:80:77.55.193.161 http://tom.tom
<html>Apache is functioning normally</html>

But it's either apache configuration issue (/usr/local/directadmin/custombuild/build rewrite_confs may help), wrong IP set or no such domain created on the server.
 

Thommen

New member
Joined
Feb 22, 2021
Messages
14
In the listings, I change the domain specifically
/usr/local/directadmin/data/users/admin/httpd.conf
<VirtualHost 77.55.193.161:80 > ServerName www.xxx.de ServerAlias www.xxx.de xxx.de ServerAdmin webmaster@xxx.de DocumentRoot /home/admin/domains/xxx.de/public_html UseCanonicalName OFF <IfModule !mod_ruid2.c> SuexecUserGroup admin admin </IfModule> CustomLog /var/log/httpd/domains/xxx.de.bytes bytes CustomLog /var/log/httpd/domains/xxx.de.log combined ErrorLog /var/log/httpd/domains/xxx.de.error.log <Directory /home/admin/domains/xxx.de/public_html> AllowOverride AuthConfig FileInfo Indexes Limit Options=Indexes,IncludesNOEXEC,MultiViews,SymLinksIfOwnerMatch,FollowSymLinks,None Options -ExecCGI -Includes +IncludesNOEXEC <FilesMatch "\.(inc|php|phtml|phps|php73)$"> <If "-f %{REQUEST_FILENAME}"> #ProxyErrorOverride on AddHandler "proxy:unix:/usr/local/php73/sockets/admin.sock|fcgi://localhost" .inc .php .phtml .php73 </If> </FilesMatch> </Directory> </VirtualHost>
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,924
Location
LT, EU
Okay, it'd be hard to say something without that domain name then. Try the real one in my curl command above.
 
Top