glib

teedee

Verified User
Joined
Oct 30, 2003
Messages
152
Hi,
I am trying to update glib (to version 1.2.6 or above), every time i run

./configure
make
make install

it all seems to go OK, however I still have

# rpm -q glib
glib-1.2.10-10


any ideas...??
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

If I'm not mistaken, you are trying to downgrade your glib from 1.2.10 to 1.2.6 ... You might consider using up2date (or apt-get).

up2date -u glib

But if you want to compile it, rpm uses a proprietary system, so if you compile software yourself, you'll be going behind the rpm system's back, so it will still think it has one version even though you've installed another.

John
 

teedee

Verified User
Joined
Oct 30, 2003
Messages
152
Actually, what I am trying to is install "Midnight Commander" text editor, but keep getting error

*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: Test for glib failed.
GNU Midnight Commander requires glib 1.2.6 or above.

Having never had a problem installing this on a box before I am starting to get pretty frustrated after spending 4 hours trying to get it working without any success..........
 

teedee

Verified User
Joined
Oct 30, 2003
Messages
152
Hi,

I tried that, still get errors

checking for glib-config... /usr/local/bin/glib-config
checking for glib-config... (cached) /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.6... *** GLIB header files (version 1.2.6) do not match
*** library (version 1.2.10)
no
configure: error: Test for glib failed.
GNU Midnight Commander requires glib 1.2.6 or above.


this is starting to get beyond annoying as MC is a text editor a number of my clients use and I have never spent more than 5 mins installing it on a cpanel server, so far am on 2nd day trying to install it on DA server....................................... and getting more and more frustrated as time goes by
 

toml

Verified User
Joined
Oct 3, 2003
Messages
1,207
Location
Scottsdale, AZ
Now you have a problem where you have more than one version of glib-config out there. You need to fully remove the older one.
 

toml

Verified User
Joined
Oct 3, 2003
Messages
1,207
Location
Scottsdale, AZ
Look at the install script for the 1.2.6 version and remove all the files it installed.

If you did a 'make install' then look for the line in the Makefile that starts with 'install:' without the quotes, everything after that begging with a tab will be part of the install.
 
Top