Help for install spamd

WebArts

Verified User
Joined
Jul 14, 2010
Messages
108
hi.
To day i try to setup spamassassin

but directadmin show this message:
Unable to setup spamassassin

Details

Spamd is not running on your system.
Click Here to learn how to enable it
directadmin showed this link:
http://help.directadmin.com/item.php?id=36

i do like order of that link but
after i do this order:
cd /usr/local/directadmin/scripts
./spam.sh
ssh work for about 1 minute and finally show this errors:
************************************************** *************************
ERROR: the required Archive::Tar module is not installed,
minimum required version is 1.23.

The "sa-update" program requires this module to access tar update
archive files.


************************************************** *************************
ERROR: the required IO::Zlib module is not installed,
minimum required version is 1.04.

The "sa-update" program requires this module to access compressed
update archive files.


************************************************** *************************
NOTE: the optional Digest::SHA module is not installed.

The Digest::SHA module is required by the DKIM plugin.

Use of uninitialized value in concatenation (.) or string at lib/Mail/SpamAssassin/Util/DependencyInfo.pm line 324.

************************************************** *************************
NOTE: the optional Mail::SPF module is installed (),
but is below the minimum required version 0,
some functionality will not be available.

Used to check DNS Sender Policy Framework (SPF) records to fight email
address forgery and make it easier to identify spams.


************************************************** *************************
NOTE: the optional IP::Country module is not installed.

Used by the RelayCountry plugin (not enabled by default) to determine
the domain country codes of each relay in the path of an email.


************************************************** *************************
NOTE: the optional Razor2 module is not installed,
minimum required version is 2.61.

Used to check message signatures against Vipul's Razor collaborative
filtering network. Razor has a large number of dependencies on CPAN
modules. Feel free to skip installing it, if this makes you nervous;
SpamAssassin will still work well without it.

More info on installing and using Razor can be found
at InstallingRazor - Spamassassin Wiki .


************************************************** *************************
NOTE: the optional Net::Ident module is not installed.

If you plan to use the --auth-ident option to spamd, you will need
to install this module.


************************************************** *************************
NOTE: the optional IO::Socket::INET6 module is not installed.

This is required if the first nameserver listed in your IP
configuration or /etc/resolv.conf file is available only via an
IPv6 address. Also used by a DCC plugin to access dccifd over network.


************************************************** *************************
NOTE: the optional Mail::DKIM module is not installed,
minimum required version is 0.31, recommended version is 0.37 or higher.

If this module is installed and the DKIM plugin is enabled,
SpamAssassin will perform DKIM signature verification when DKIM-Signature
header fields are present in the message headers, and check ADSP rules
(e.g. anti-phishing) when a mail message does not contain a valid author
domain signature. Version 0.37 or later is needed to fully support ADSP.


************************************************** *************************
NOTE: the optional Encode::Detect module is not installed.

If you plan to use the normalize_charset config setting to detect
charsets and convert them into Unicode, you will need to install
this module.

REQUIRED module missing: Archive::Tar
REQUIRED module missing: IO::Zlib
optional module missing: Digest::SHA
optional module out of date: Mail::SPF
optional module missing: IP::Country
optional module missing: Razor2
optional module missing: Net::Ident
optional module missing: IO::Socket::INET6
optional module missing: Mail::DKIM
optional module missing: Encode::Detect

warning: some functionality may not be available,
please read the above report before continuing!

make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.
Cannot find /usr/bin/sa-update after install. Check for errors above.


run:
/usr/bin/spamd -d -c -m 15
and i can not run /usr/bin/spamd -d -c -m 15 because show this error:

-bash: /usr/bin/spamd: No such file or directory
please help me for install spamd.
thanks
 
Last edited:

alphadeity

Verified User
Joined
Jun 16, 2010
Messages
48
You need to let us know what OS your server is running.

From the error messages, you don't have the proper perl modules installed on you server.

If you're running a varietion of centos, then run the following commands.

yum install perl-archive-tar perl-io-zlib

And then install any optional modules u wish.

Then rebuild spamd.
 

WebArts

Verified User
Joined
Jul 14, 2010
Messages
108
i did yum install perl-archive-tar perl-io-zlib but:

Setting up Install Process
No package perl-archive-tar available.
* Maybe you meant: perl-Archive-Tar
No package perl-io-zlib available.
* Maybe you meant: perl-IO-Zlib
Nothing to do
=> yum install perl-Archive-Tar perl-IO-Zlib
 
Last edited:
Top