HOW TO : MailScanner

koh

Verified User
Joined
Dec 3, 2005
Messages
167
Location
Singapore
Personally I find Michele's guide useful too, heres the link:

http://www.mneylon.com/blog/archives/2006/01/16/installing-mailscanner-on-directadmin-with-exim/

If you followed Michele's guide, and you want to uninstall mailscanner, the following is the steps:

first, verify that /etc/exim.back and /etc/init.d/exim.orig is fine. Once verified, key the following in ssh:rpm -e mailscanner

The command will remove all the files installed by mailscanner. Next up, we will
remove exim symlink in /etc/init.d and rename exim.orig to exim
and /etc/exim.back to exim.conf.
By doing so, the exim should be revert to it’s previous state.

Now, remove the following directories:

#rm -f /var/spool/exim.in
#rm -f /var/spool/exim.in/input
#rm -f /var/spool/exim.in/data
#rm -f /var/spool/exim.in/db
#rm -f /usr/local/exim/
#rm -f /usr/local/exim/bin

now do a restart exim command and see if it work

#service exim restart
and the uninstallation is done.
 

@how@

Verified User
Joined
Mar 2, 2005
Messages
961
Location
Kingdom of Bahrain
if you want use it wait ClamAV just sent
Code:
Virus Scanners = auto
and remove clamav from exim.cont then restart mailscanner.
in corn add
Code:
42          * * * * root /opt/MailScanner/bin/update_virus_scanners

Wael
 

arutha

Verified User
Joined
Aug 25, 2005
Messages
38
Location
Australia
Mail doesnt appear to be coming in from external sources. I have tested locally and with some sources such as my ISP webmail and hotmail.

Any suggestions as to where i should be looking?

Edit** Reverted to original exim.conf and it is working. Not sure where to be looking though
 
Last edited:

bluecherry

Verified User
Joined
Oct 3, 2006
Messages
14
Does mailscanner need to be triggered by a custom init.d script or does it start automatically?

Thx!
 

arutha

Verified User
Joined
Aug 25, 2005
Messages
38
Location
Australia
The cron job will start its update periodocally and the MTA will pass mail to be scanned when setup correctly from what I can gather. (eg. no)
 

wildnight

Verified User
Joined
Oct 16, 2006
Messages
6
Question! I install Spamassasin whit mailscanner and clamAV. The process is working find but i dont received the email in my mailbox! I have to restart exim and all mail a deliver! Somebody have an idea?

Thanks!
 

bluecherry

Verified User
Joined
Oct 3, 2006
Messages
14
Hi,

after I successfully setup mailscanner on a previous server, I'm experiencing trouble on a new one.

I followed the instructions from a - z except for:
* using version 4.56.8 instead of 4.55.10
* installing bitdefender, clamav and spamassasin before installing mailscanner
* using the mailscanner clamav/SA installer script

Mail is getting through and whenever email is processing I see 2 exim processes.

When I look at the messages in my inbox I see NO:
* mailscanner signature
* changes to the headers at all (no spamassassin nor mailscanner headers)

I've got up to 6 mailscanner instances running, this number doesn't change when exim is processing email.

Please find some recent log excerpts attached.

I hope somebody is still following up on this thread :s.


Thx!

/var/log/mail.log
Code:
Nov  9 18:58:50 vm01-debian MailScanner[31191]: MailScanner E-Mail Virus Scanner version 4.56.8 starting... 
Nov  9 18:58:51 vm01-debian MailScanner[31191]: Read 755 hostnames from the phishing whitelist 
Nov  9 18:58:52 vm01-debian MailScanner[31191]: Using SpamAssassin results cache 
Nov  9 18:58:52 vm01-debian MailScanner[31191]: Connected to SpamAssassin cache database 
Nov  9 18:58:52 vm01-debian MailScanner[31191]: Enabling SpamAssassin auto-whitelist functionality... 
Nov  9 18:58:54 vm01-debian MailScanner[31191]: Using locktype = posix 
Nov  9 18:58:54 vm01-debian MailScanner[31191]: Creating hardcoded struct_flock subroutine for linux (Linux-type) 
Nov  9 18:59:02 vm01-debian MailScanner[31234]: MailScanner E-Mail Virus Scanner version 4.56.8 starting... 
Nov  9 18:59:02 vm01-debian MailScanner[31234]: Read 755 hostnames from the phishing whitelist 
Nov  9 18:59:03 vm01-debian MailScanner[31234]: Using SpamAssassin results cache 
Nov  9 18:59:03 vm01-debian MailScanner[31234]: Connected to SpamAssassin cache database 
Nov  9 18:59:03 vm01-debian MailScanner[31234]: Enabling SpamAssassin auto-whitelist functionality... 
Nov  9 18:59:05 vm01-debian MailScanner[31234]: Using locktype = posix 
Nov  9 18:59:05 vm01-debian MailScanner[31234]: Creating hardcoded struct_flock subroutine for linux (Linux-type)
....
Code:
Nov  9 19:03:03 vm01-debian MailScanner[31171]: New Batch: Scanning 1 messages, 976 bytes 
Nov  9 19:03:03 vm01-debian MailScanner[31171]: Virus and Content Scanning: Starting 
Nov  9 19:03:11 vm01-debian MailScanner[31171]: Uninfected: Delivered 1 messages
 
Last edited:

roly

Verified User
Joined
Nov 9, 2006
Messages
203
hi

i installed mailscanner after intalling clamav and spamassassin using the update script. however when reading the log i seem to get these errors:

Nov 21 14:05:33 myhost MailScanner[31869]: MailScanner E-Mail Virus Scanner version 4.55.10 starting...
Nov 21 14:05:34 myhost MailScanner[31869]: Read 748 hostnames from the phishing whitelist
Nov 21 14:05:34 myhost MailScanner[31869]: You want to use SpamAssassin but have not installed it.
Nov 21 14:05:34 myhost MailScanner[31869]: Please download http://www.sng.ecs.soton.ac.uk/mailscanner/files/4/install-Clam-SA.tar.gz and unpack it and run ./install.sh to install it, then restart MailScanner.
Nov 21 14:05:34 myhost MailScanner[31869]: I will run without SpamAssassin for now, you will not detect much spam until you install SpamAssassin.
Nov 21 14:05:34 myhost MailScanner[31869]: Using locktype = posix
Nov 21 14:05:34 myhost MailScanner[31869]: Creating hardcoded struct_flock subroutine for linux (Linux-type)
Nov 21 14:05:34 myhost MailScanner[31869]: New Batch: Found 108 messages waiting
Nov 21 14:05:34 myhost MailScanner[31869]: New Batch: Scanning 30 messages, 44211 bytes
Nov 21 14:05:34 myhost MailScanner[31869]: Virus and Content Scanning: Starting
Nov 21 14:05:36 myhost MailScanner[31869]: ERROR: Unable to open file or directory


has anyone got any idea what file or directory it is refering to that it says it can't open? it also says spamassasin isn't intstalled but it is, any ideas there also?

thanks in advance

roland
 

SupermanInNY

Verified User
Joined
Sep 28, 2004
Messages
350
What exactly is MailScanner?
How is it different than just running SpamAssasin and ClamAV?
I'm sorry that this is such a simple question, I just didn't see an explanation of what it doesn, or how is it different than the current run of SA + ClamAV.

Thanks,

-Alon.
 

prexk

New member
Joined
Oct 5, 2005
Messages
4
Question : How do you flush the queued /defered emails in MailScanner ?

Without MailScanner..I know how to force delivery but under MailScanner, I'm not sure how..
 

antpeks

Verified User
Joined
Jun 29, 2006
Messages
26
Location
Antwerpen
today i installed the mailscanner according to this thread, my maillog is saying this.

Dec 18 22:08:43 server MailScanner[26732]: Read 748 hostnames from the phishing whitelist
Dec 18 22:08:45 server vm-pop3d[26610]: User 'beter' logged in from 86.86.8x.xx, nmsgs=0
Dec 18 22:08:45 server vm-pop3d[26610]: Session ended for user: 'beter' from 86.86.8x.xx, nmsgs=0, ndel=0
Dec 18 22:08:52 server MailScanner[26739]: MailScanner E-Mail Virus Scanner version 4.55.10 starting...
Dec 18 22:08:53 server MailScanner[26739]: Could not read directory /usr/sbin/exim
Dec 18 22:08:53 server MailScanner[26739]: Error in configuration file line 153, directory /usr/sbin/exim -C /etc/exim_outgoing.conf for outqueuedir does not exist (or is not readable)

Anyone care to help me out, server is running at cent os 4.4 and latest DA

Peter
 

mbear

Verified User
Joined
Oct 31, 2006
Messages
14
Mail doesnt appear to be coming in from external sources. I have tested locally and with some sources such as my ISP webmail and hotmail.

Any suggestions as to where i should be looking?

Edit** Reverted to original exim.conf and it is working. Not sure where to be looking though
Did you get this fixed? I installed and found exactly the same result. But nothing anywhere to help fix it. Only thing I can think of is that it's a conflict with SpamBlocker, which is now built in and activated by default in DirectAdmin...
 
Top