How-to: phpMyAdmin 3.0.0

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,123
Location
LT, EU
Code:
wget -O /usr/local/directadmin/scripts/packages/phpMyAdmin-3.0.0-all-languages.tar.gz http://dfn.dl.sourceforge.net/sourceforge/phpmyadmin/phpMyAdmin-3.0.0-all-languages.tar.gz
tar xzf /usr/local/directadmin/scripts/packages/phpMyAdmin-3.0.0-all-languages.tar.gz -C /var/www/html
cp -f /var/www/html/phpMyAdmin-3.0.0-all-languages/config.sample.inc.php /var/www/html/phpMyAdmin-3.0.0-all-languages/config.inc.php
perl -pi -e "s#\['auth_type'\] = 'cookie'#\['auth_type'\] = 'http'#" /var/www/html/phpMyAdmin-3.0.0-all-languages/config.inc.php

#Hooray! We have mysqli support now :)
perl -pi -e "s#\['extension'\] = 'mysql'#\['extension'\] = 'mysqli'#" /var/www/html/phpMyAdmin-3.0.0-all-languages/config.inc.php

chown -f -R webapps:webapps /var/www/html/phpMyAdmin-3.0.0-all-languages
chmod -f 755 /var/www/html/phpMyAdmin-3.0.0-all-languages
chmod 000 /var/www/html/phpMyAdmin-3.0.0-all-languages/scripts
rm -f /var/www/html/phpMyAdmin
ln -s /var/www/html/phpMyAdmin-3.0.0-all-languages /var/www/html/phpMyAdmin
Good luck! :)
 

paix

Verified User
Joined
Oct 31, 2006
Messages
55
Location
ua
Hi! Also It would be good to do a redirect to https for phpmyadmin.
I've tried as described here: http://robsnotebook.com/xampp-ssl-encrypt-passwords

but it dosn't work.

Code:
# less /usr/local/etc/apache2/Includes/httpd-alias.conf

Alias /phpmyadmin "/usr/local/www/phpMyAdmin/"

<IfModule mod_rewrite.c>
    RewriteEngine On
    # Redirect /phpMyAdmin folder to https
    RewriteCond %{HTTPS} !=on
    RewriteCond %{REQUEST_URI} /phpmyadmin
    RewriteRule ^(.*) https://%{SERVER_NAME}$1 [R,L]
</IfModule>
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,123
Location
LT, EU
Code:
cd /usr/local/directadmin/custombuild
./build update
./build php n
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,123
Location
LT, EU
Try:
Code:
cd /usr/local/directadmin/custombuild
./build update
perl -pi -e 's/mysql_inst=no/mysql_inst=yes/' options.conf
./build mysql
./build php n
 

tycoon35

Verified User
Joined
Sep 28, 2008
Messages
11
Try:
Code:
cd /usr/local/directadmin/custombuild
./build update
perl -pi -e 's/mysql_inst=no/mysql_inst=yes/' options.conf
./build mysql
./build php n
Should I keep backups of my current Databases? Can it remove them?

Do I need to do the whole thing again? or this will be fine
perl -pi -e 's/mysql_inst=no/mysql_inst=yes/' options.conf
./build mysql
./build php n
It went fine previous time..

& I am really new to these things...:eek:
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,123
Location
LT, EU
It won't remove your databases :) But if you want - make a backup. You need to enter custombuild directory (so you need a "cd" command).
 

tycoon35

Verified User
Joined
Sep 28, 2008
Messages
11
Fixed...

Thanks X 100

I can update the phpmyadmin now right ? :)

Is 3.0.1-rc1 recommended?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,123
Location
LT, EU
Yes, you can :) If you want to try 3.0.1-rc1 - just change 3.0.0 to 3.0.1-rc1 in my how-to.
 

tycoon35

Verified User
Joined
Sep 28, 2008
Messages
11
Code:
wget -O /usr/local/directadmin/scripts/packages/phpMyAdmin-3.0.0-all-languages.tar.gz http://dfn.dl.sourceforge.net/sourceforge/phpmyadmin/phpMyAdmin-3.0.0-all-languages.tar.gz
tar xzf /usr/local/directadmin/scripts/packages/phpMyAdmin-3.0.0-all-languages.tar.gz -C /var/www/html
cp -f /var/www/html/phpMyAdmin-3.0.0-all-languages/config.sample.inc.php /var/www/html/phpMyAdmin-3.0.0-all-languages/config.inc.php
perl -pi -e "s#\['auth_type'\] = 'cookie'#\['auth_type'\] = 'http'#" /var/www/html/phpMyAdmin-3.0.0-all-languages/config.inc.php

#Hooray! We have mysqli support now :)
perl -pi -e "s#\['extension'\] = 'mysql'#\['extension'\] = 'mysqli'#" /var/www/html/phpMyAdmin-3.0.0-all-languages/config.inc.php

chown -f -R webapps:webapps /var/www/html/phpMyAdmin-3.0.0-all-languages
chmod -f 755 /var/www/html/phpMyAdmin-3.0.0-all-languages
chmod 000 /var/www/html/phpMyAdmin-3.0.0-all-languages/scripts
rm -f /var/www/html/phpMyAdmin
ln -s /var/www/html/phpMyAdmin-3.0.0-all-languages /var/www/html/phpMyAdmin
Good luck! :)
Replaced with 3.0.1-rc1 & I got this error in the second step(untar)

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: error exit delayed from previous errors
with 3.0.0 it went fine...but at last http://myip/phpmyadmin shows "404 not found!" :(

This is present in /var/www
phpMyAdmin -> /var/www/html/phpMyAdmin-3.0.0-all-languages
EDIT: did it :D changed it simply to html

Thank you very much :)
 
Last edited:

xtrails

New member
Joined
Nov 15, 2008
Messages
3
phpMyAdmin - Error You should upgrade to MySQL 5.0.15 or later.

Hi I've a directadmin on dedicated server new installed. But I get this messages When acces the php admin:

phpMyAdmin - Error

You should upgrade to MySQL 5.0.15 or later.


the servers configuration is :
Apache 2.2.10 Running
DirectAdmin Running
Exim 4.67 Running
MySQL 4.1.10 Running
Named 9.3.4 Running
ProFTPd 1.3.1 Running
sshd Running
dovecot 1.1.6 Running


One other error to: when I upload sql file I get this error...

Error Restoring database

Details

Unable to restore database domaintod_articless : sh: /usr/bin/gunzip: No such file or directory ERROR 1045 (28000): Access denied for user 'xxxxxxx'@'localhost' (using password: YES)


Please help me this..
Thanks
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,123
Location
LT, EU
Code:
cd /usr/local/directadmin/custombuild
./build update
perl -pi -e 's/mysql_inst=no/mysql_inst=yes/' options.conf
perl -pi -e 's/mysql_backup=no/mysql_backup=yes/' options.conf
./build mysql
 

xtrails

New member
Joined
Nov 15, 2008
Messages
3
but I'dont want to update mysql version

I want to fix this problem but I'dont want to update mysql version ! what can I do
 

xtrails

New member
Joined
Nov 15, 2008
Messages
3
ok I uploadt it

I Upload my server phpmyadmin 2.5 and it work normally. But how can I downgrade servers phpmyadmin please write me servers command.

Thanks
 

webguy

Verified User
Joined
Apr 13, 2005
Messages
41
Location
Best, Netherlands
I also have the issue with "You should upgrade to MySQL 5.0.15 or later".
My options.conf has the following settings:

#Possible values - 4.1, 5.0, 5.1
mysql=5.0
mysql_inst=yes
mysql_backup=yes

When I check php -i I see:

mysql

MySQL Support => enabled
Active Persistent Links => 0
Active Links => 0
Client API version => 5.0.81
MYSQL_MODULE_TYPE => external
MYSQL_SOCKET => /var/lib/mysql/mysql.sock
MYSQL_INCLUDE => -I/usr/include/mysql
MYSQL_LIBS => -L/usr/lib -lmysqlclient

Should I re-install mysql ?
 
Top