I can't update php by running ./build all d! weird nginx error

redjersey

Verified User
Joined
Apr 22, 2013
Messages
93
Location
Toronto, Canada
I got a really weird error when running ./build all d. I don't have nginx enabled, I only use apache 2 but when I run:
./build all d

I got the error message saying:

configure: error: unrecognized option: --user=nginx
Try `./configure --help' for more information.

*** There was an error while trying to configure Apache 2. Check the custom/nginx/configure.nginx file

this is my options.conf:

Code:
#PHP settings.
#Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, 5.5, no. php1/php2_mode: mod_php, fastcgi,$
php1_release=5.3
php2_release=no
php1_mode=mod_php
php2_mode=php-fpm
php_ini=no
php_timezone=EDT
#Possible values - production or development
php_ini_type=production
ioncube=yes
zend=yes

#HTTP server. Possible values: apache, nginx
webserver=apache

#Apache settings
#Possible value: 2.4
apache_ver=2.4
mod_ruid2=yes
secure_htaccess=no
harden-symlinks-patch=yes
use_hostname_for_alias=no
redirect_host=server.mydomain.com
redirect_host_https=no

#Possible values - 5.1, 5.5, 5.6
mysql=5.6
mysql_inst=no
mysql_backup=yes
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups

#Web applications
phpmyadmin=yes
squirrelmail=yes
roundcube=yes

#Mail options
exim=no
eximconf=no
clamav=yes
spamassassin=yes
dovecot=yes
pigeonhole=no

#Statistics
awstats=yes
webalizer=yes

#FTP options - possible values: proftpd, pureftpd
ftpd=pureftpd

#Jailed shell
jail=no

#Autoconf/automake/libtool options
autoconf=yes
automake=yes
libtool=yes
curl=yes

#new version of zlib and libxml2 (experts only)
zlib=no
new_zlib=no
new_xml2=yes
new_pcre=no

#Custombuild options
custombuild=2.0
autover=no
bold=yes
clean=yes
cleanapache=no
clean_old_tarballs=yes
clean_old_webapps=yes
downloadserver=files.directadmin.com
and here is my configure.nginx

Code:
#!/bin/sh
./configure \
	"--user=nginx" \
        "--group=nginx" \
        "--prefix=/usr" \
        "--sbin-path=/usr/sbin" \
        "--conf-path=/etc/nginx/nginx.conf" \
        "--pid-path=/var/run/nginx.pid" \
        "--http-log-path=/var/log/nginx/access_log" \
        "--error-log-path=/var/log/nginx/error_log" \
        "--with-ipv6" \
        "--without-mail_imap_module" \
        "--without-mail_smtp_module" \
        "--with-http_ssl_module" \
        "--with-http_stub_status_module" \
        "--with-http_gzip_static_module" \
        "--with-cc-opt='-D FD_SETSIZE=32768'"
I guess that some files must have accidentally compile the configure.nginx, even I'm not using nginx.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,789
Location
LT, EU
I found a bug and fixed it in CustomBuild 2.0 (not uploaded to DA severs yet). You seem to have custom/nginx/configure.nginx, however, you don't use nginx at all, am I right? Just remove it and it will fix the problem for now. Thank you for the report.
 

redjersey

Verified User
Joined
Apr 22, 2013
Messages
93
Location
Toronto, Canada
I have removed the custom/nginx/configure.nginx and now it's fine :)

I had to customize my configure.php5X and I have read somewhere else (probably http://forum.directadmin.com/showthread.php?t=44743) that I had to copy the whole configure folder as custom and modify the configure.php5x from custom instead of configure

so I guess that's why I got custom/nginx/configure.nginx inside my custom folder

now I can finally run ./build all d.
thanks man!
 
Top