I need someone to install DA on VPS cent6_64 PHP 5.2.17

pico

Verified User
Joined
Apr 4, 2008
Messages
5
Hi,
I need to install DirectAdmin on my VPS cen6_64. What I need is PHP 5.2.17, Mysql 5.1.
Let's PM me price.
thanks
 

SmallWeb

Verified User
Joined
Jul 1, 2019
Messages
57
https://help.directadmin.com/item.php?id=497 seems to indicate that the CloudLinux extended support version of 6 is supported.

You can change your php version in /usr/local/directadmin/custombuild/options.conf or via the following commands (post-install):
Code:
cd /usr/local/directadmin/custombuild
./build update
./build set php1_release 5.2
Samething for MySQL (post-install):
Code:
cd /usr/local/directadmin/custombuild
./build set mysql 5.1
./build set mysql_inst mysql
./build set mysql_backup yes
./build update
./build mysql
As far as the installation of DirectAdmin. Anything in particular you don't like or understand or this is just for convenience? The install guide is pretty straight forward. I don't use CentOS6 so take it with a pinch of salt.
 

tristan

Verified User
Joined
Feb 11, 2005
Messages
420
Location
The Netherlands
Sorry I meant that PHP version isn't actually supported anymore:
  • php1_release - select the default PHP release which you would like to get installed/updated using "./build php" or "./build all". Possible values: 5.3/5.4/5.5/5.6/7.0/7.1/7.2/7.3/7.4 (default: 7.2).
 

SmallWeb

Verified User
Joined
Jul 1, 2019
Messages
57
Sorry I meant that PHP version isn't actually supported anymore:
Ah, good spot, thank you.

So I think the only hope for OP is by using CloudLinux for the PHP selector (assuming you can enable 5.2 through that?) and Hardened CentOS6.
 

Sevu

New member
Joined
Jan 18, 2020
Messages
4
CHange your OS to debian 9 and install scripts before install script for setup.sh ;)
 

Aar

Verified User
Joined
Feb 10, 2005
Messages
97
Location
Netherlands
Why did you need the old branch of PHP 5.2?
Is it not more convenient to solve the problem?
 
Top