imagick update issue in custombuild 2

pandappa

New member
Joined
Jan 31, 2020
Messages
3
Hi Guys

Having an issue with CustomBuild 2 and imagick. I used

pecl install imagick

to install imagick and it looks to have installed OK.

Build process completed successfully
Installing '/usr/local/include/php/ext/imagick/php_imagick_shared.h'
Installing '/usr/local/lib/php/extensions/no-debug-non-zts-20170718/imagick.so'
install ok: channel://pecl.php.net/imagick-3.4.4
configuration option "php_ini" is not set to php.ini location
You should add "extension=imagick.so" to php.ini
[root@pandvps01 pandappa]# echo extension=imagick.so >> /etc/php.ini


However CustomBuild is still showing imagick needs an update from 0 to 3.4.4. If I run the update from CustomBuild I get the following

  • Executing /usr/local/directadmin/plugins/custombuild/admin/build imagick...
  • Installing imagick-3.4.4 PHP extension for PHP 72...
  • Found /usr/local/directadmin/custombuild/imagick-3.4.4.tgz
  • Extracting /usr/local/directadmin/custombuild/imagick-3.4.4.tgz...
  • /usr/local/directadmin/custombuild/build: line 14574: /usr/local/php72/bin/phpize: No such file or directory
  • /usr/local/directadmin/custombuild/build: line 14578: ./configure: No such file or directory
  • Trying to make imagick-3.4.4 PHP extension...
  • make: *** No targets specified and no makefile found. Stop.
  • Done!
Any ideas what's happening here and how I can tidy this up?

Many thanks

P
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,095
Location
LT, EU
Hi Guys

Having an issue with CustomBuild 2 and imagick. I used

pecl install imagick

to install imagick and it looks to have installed OK.

Build process completed successfully
Installing '/usr/local/include/php/ext/imagick/php_imagick_shared.h'
Installing '/usr/local/lib/php/extensions/no-debug-non-zts-20170718/imagick.so'
install ok: channel://pecl.php.net/imagick-3.4.4
configuration option "php_ini" is not set to php.ini location
You should add "extension=imagick.so" to php.ini
[root@pandvps01 pandappa]# echo extension=imagick.so >> /etc/php.ini


However CustomBuild is still showing imagick needs an update from 0 to 3.4.4. If I run the update from CustomBuild I get the following

  • Executing /usr/local/directadmin/plugins/custombuild/admin/build imagick...
  • Installing imagick-3.4.4 PHP extension for PHP 72...
  • Found /usr/local/directadmin/custombuild/imagick-3.4.4.tgz
  • Extracting /usr/local/directadmin/custombuild/imagick-3.4.4.tgz...
  • /usr/local/directadmin/custombuild/build: line 14574: /usr/local/php72/bin/phpize: No such file or directory
  • /usr/local/directadmin/custombuild/build: line 14578: ./configure: No such file or directory
  • Trying to make imagick-3.4.4 PHP extension...
  • make: *** No targets specified and no makefile found. Stop.
  • Done!
Any ideas what's happening here and how I can tidy this up?

Many thanks

P
What’s the version of the custombuild script? I guess it might be an outdated version.
 

pandappa

New member
Joined
Jan 31, 2020
Messages
3
Hi smtalk

Sorry, still a Linux newb, how can i tell the version of the script?

Cheers
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,095
Location
LT, EU
It’s shown in top left of the plugin :) Update button is on top-right if you’d like to give it a try with the latest version.
 

pandappa

New member
Joined
Jan 31, 2020
Messages
3
Ah righto, its 2.0.0 (rev: 2384)

Same problem

  • Executing /usr/local/directadmin/plugins/custombuild/admin/build update_versions...
  • [1mUpdating imagick(B[m
  • Installing imagick-3.4.4 PHP extension for PHP 72...
  • Found /usr/local/directadmin/custombuild/imagick-3.4.4.tgz
  • Extracting /usr/local/directadmin/custombuild/imagick-3.4.4.tgz...
  • /usr/local/directadmin/custombuild/build: line 14582: /usr/local/php72/bin/phpize: No such file or directory
  • /usr/local/directadmin/custombuild/build: line 14586: ./configure: No such file or directory
  • Trying to make imagick-3.4.4 PHP extension...
  • make: *** No targets specified and no makefile found. Stop.
  • Done!
 

Attachments

Top