IMAP Server Error 111

danelson64

Verified User
Joined
Oct 24, 2008
Messages
5
When attempting to login to webmail, I receive the following error:

SquirrelMail

Error
Error connecting to IMAP server: localhost.
111 : Connection refused
 

scsi

Verified User
Joined
Aug 19, 2008
Messages
4,695
Is the imap server running?

Do you have a firewall blocking imap?
 

danelson64

Verified User
Joined
Oct 24, 2008
Messages
5
I apologize for not being Linux savvy, but what command should I run at the command prompt to detremine if the IMAP server is running?
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
from your server:
Code:
telnet localhost 143
I have no idea how to properly disconnect; I generally do it by sending quit; it appears to take ten times before it disconnects.

Jeff
 

gozargah

Verified User
Joined
Oct 21, 2008
Messages
35
i have:

[root@server custombuild]# telnet localhost 143
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
* OK Dovecot DA ready.

* BAD Error in IMAP command received by server.

* BAD Error in IMAP command received by server.

* BAD Error in IMAP command received by server.

* BAD Error in IMAP command received by server.


Is this good?
 

Voland

Verified User
Joined
May 21, 2005
Messages
67
Hello!

you need to change localhost record in your "/etc/hosts" to
127.0.0.1 localhost localhost.localdomain
 

gozargah

Verified User
Joined
Oct 21, 2008
Messages
35
Here is my current configuration:

127.0.0.1 localhost localhost.localdomain
1*3.***.***.1*0 server.p******s.com


Is this true?
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
And Voland, if you'd look at the first post you'd see that localhost was already pointing to 127.0.0.1 when gozargah asked the original question.

gozargah, I don't have any idea why your imap server is returning those errors. Perhaps you should reinstall (or have someone else reinstall) dovecot.

Jeff
 

birk

New member
Joined
Oct 27, 2010
Messages
1
I know this is an old post but here is the answer

be sure that
127.0.0.1 localhost
is at the bottom of the /etc/localhost

or

Run the ...htdocs/squirrelmail/configure
option 2 server settings
option A update IMAP settings
option 4 and either put 127.0.0.1 or the ipaddress of the imap server.
You will have to do the same for SMTP

Rance
 
Top