Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion

kastin

New member
Joined
Jan 5, 2015
Messages
2
Fresh DA install:
1) add " deb http://ftp.debian.org/debian experimental main" at sources.list
2) apt-get install mysql-client-5.6 (or 5.5)
3) wait a moment and restart mysqld.

got:
Code:
# mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Seems to /home/mysql destroyed, so run:
Code:
 #cd /usr/local/directadmin/custombuild
# ./build mysql
Attempting to compile a package from source...
File already exists
MD5 Checksum on mysql-5.6.24.tar.gz passed.
Extracting mysql-5.6.24.tar.gz ... 
Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!
Done. Making mysql-5.6.24...
Trying to make mysql-5.6.24...
make: *** No targets specified and no makefile found.  Stop.

*** The make has failed, would you like to try to make again? (y,n): 
n
Can not reinstall mysql..
What could be wrong?
 

Perfh

Verified User
Joined
Aug 19, 2007
Messages
18
Location
France
Hello,

I've the same problem, I had installed DA on Ubuntu 14.04 (with debian 7 binary because debian 8 binary don't work on ubuntu 14.04).

All work fine I've mysql 5.6.12 by default, but i want update to 5.6.24 with custombuild but I've this message :

Code:
root@ns1:/usr/local/directadmin/custombuild# ./build mysql
Warning: Using a password on the command line interface can be insecure.
       Dumping database mysql 
Warning: Using a password on the command line interface can be insecure.
--2015-06-06 15:19:26--  [url]http://files4.directadmin.com/services/all/mysql/debian/64-bit/mysql-5.6.25-linux-x86_64.tar.gz[/url]
Resolving files4.directadmin.com (files4.directadmin.com)... 193.105.61.16
Connecting to files4.directadmin.com (files4.directadmin.com)|193.105.61.16|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-06-06 15:19:26 ERROR 404: Not Found.

Attempting to compile a package from source...
Found old mysql-5.6.25, removing ...
Extracting mysql-5.6.25.tar.gz ... 
Inconsistency detected by ld.so: dl-version.c: 224: _dl_check_map_versions: Assertion `needed != ((void *)0)' failed!
Done. Making mysql-5.6.25...
Trying to make mysql-5.6.25...
make: *** No targets specified and no makefile found.  Stop.

*** The make has failed, would you like to try to make again? (y,n):
Apparmor is disabled, what can I do ? thank you for help
 
Last edited:
Top