Install Nearly Worked on Ubuntu18.04

OIL710

Verified User
Joined
Mar 24, 2010
Messages
16
Location
Australia
After doing a fresh Unbutu18.04 OS install on my VPS, running apt-get update and apt-get upgrade,
I tried to install the free DA licence from my VPS provider.

I ran the suggested pre installs for Debian-10 as suggested. No errors there.

Next I ran the install.sh (with the auto parameter) which ran for over 95 minutes, and showed no errors that I saw.

Then I get the below series of error messages "not found" "no such file" "cannot find" and so DA will not run.

I then tried again without the auto param, and left the ClientID and License values blank ( I had none), but put in my IP.

This failed after about a minute with... with
"You are not authorized to download the update package with that client id and license id for this IP address."

My host has set my IP OK within DA, but I have no clientid of licenseid to set when the install runs.

Here is what I see after the install ran:

Code:
 *************************************                                                                                                                
*                                  *                                                                                                                  
*   All parts have been installed   *                                                                                                                
*                                  *                                                                                                                  
*************************************                                                                                                                
                                                                                                                                                     
Type: systemctl restart httpd.service                                                                                                                
./directadmin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./directadmin)                                            
./directadmin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./directadmin)                                            
Can't open /usr/local/directadmin/data/admin/services.status: No such file or directory.

What to do next? Thanks.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,329
Location
LT, EU
After doing a fresh Unbutu18.04 OS install on my VPS, running apt-get update and apt-get upgrade,
I tried to install the free DA licence from my VPS provider.

I ran the suggested pre installs for Debian-10 as suggested. No errors there.

Next I ran the install.sh (with the auto parameter) which ran for over 95 minutes, and showed no errors that I saw.

Then I get the below series of error messages "not found" "no such file" "cannot find" and so DA will not run.

I then tried again without the auto param, and left the ClientID and License values blank ( I had none), but put in my IP.

This failed after about a minute with... with
"You are not authorized to download the update package with that client id and license id for this IP address."

My host has set my IP OK within DA, but I have no clientid of licenseid to set when the install runs.

Here is what I see after the install ran:

Code:
 *************************************                                                                                                               
*                                  *                                                                                                                 
*   All parts have been installed   *                                                                                                               
*                                  *                                                                                                                 
*************************************                                                                                                               
                                                                                                                                                    
Type: systemctl restart httpd.service                                                                                                               
./directadmin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./directadmin)                                           
./directadmin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./directadmin)                                           
Can't open /usr/local/directadmin/data/admin/services.status: No such file or directory.

What to do next? Thanks.
Wrong OS in the license. It needs to be set to Linux 64bit.
 

OIL710

Verified User
Joined
Mar 24, 2010
Messages
16
Location
Australia
I fixed my OS type and ran setup.sh again.
It seems to have got it working now, but I cannot login with the admin password I got from /usr/local/directadmin/scripts/setup.txt
Using ssh as root I also tried passwd admin
but that reports user 'admin' does not exist

systemctl reports directadmin IS running, and I can see the DA login page via my browser at IP:2222

Is there somewhere else to look or some other method?
 

OIL710

Verified User
Joined
Mar 24, 2010
Messages
16
Location
Australia
Problem FIXED

I tried editing the setup.txt file and put in a new password for admin.
Then I ran /usr/local/directadmin/directadmin i
I answered y to do you want to reinstall.....

It now works, I can login at nnn.nnn.nnn.nnn:2222 as admin and the password I set in setup.txt

Looking good.
 
Top