Installing GMP extension

jayw1

Verified User
Joined
Nov 20, 2019
Messages
127
Location
USA
I have this,

PHP (default) configuration file: /usr/local/directadmin/custombuild/custom/litespeed/configure.php74
PHP (additional) configuration file: /usr/local/directadmin/custombuild/configure/php/configure.php73

configure.php74 has --with-gmp but I want to install it for PHP 7.3 as well.

I copied /usr/local/directadmin/custombuild/configure/litespeed/configure.php73 to /usr/local/directadmin/custombuild/custom/litespeed/ and added --with-gmp \ in the middle of the file.
When running ./build php n, I get this error:

configure: error: GNU MP Library version 4.2 or greater required.
*** There was an error while trying to configure php. Check the configure file


Did I miss a step? What have I done wrong? Any idea @smtalk? :)
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
127
Location
USA
The problem is push notifications in Xenforo.

  • ErrorException: [E_USER_WARNING] [WebPush] gmp extension is not loaded but is required for sending push notifications with payload or for VAPID authentication. You can fix this in your php.ini.
  • src/vendor/minishlink/web-push/src/WebPush.php:72
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
127
Location
USA
I've installed gmp-devel and now PHP is rebuilding, will report back if it works.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
670
Location
Murfreesboro
Add it in the custom build plugin under custom complie
Pull the drop down and find whichever php you have in options
 
Top