installing on Centos 8.2 - Apache prerequisite failures


Verified User
Jul 6, 2019
I also get the error on an empty installation of centos 8.3

checking for nghttp2... checking for user-provided nghttp2 base directory... none
checking for pkg-config along /usr/local/icu/lib/pkgconfig:/usr/local/lib64/pkgconfig:/usr/local/lib/pkgconfig:/usr/lib/x86_64-linux-gnu/pkgconfig... checking for nghttp2 version >= 1.2.1... FAILED
configure: WARNING: nghttp2 version is too old
checking whether to enable mod_http2... configure: error: mod_http2 has been requested but can not be built due to prerequisite failures

*** There was an error while trying to configure Apache 2. Check the configure/ap2/configure.apache file

Operating System: CentOS Linux 8
CPE OS Name: cpe:/o:centos:centos:8
Kernel: Linux 4.18.0-240.1.1.el8_3.x86_64
Architecture: x86-64
I can confirm the same on CentOS 8.3 (Already converted to CL 8)
Fixed it by running
yum install libnghttp2-devel

Then I got another issue

configure: error: Package requirements (oniguruma) were not met: Package 'oniguruma', required by 'virtual:world', not found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables ONIG_CFLAGS and ONIG_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details. *** There was an error while trying to configure php. Check the configure file PHP has been secured. Restarting php-fpm74.

I converted back to plain CentOS and installed Direct Admin on CentOS 8.3 without an issue. Guessing there are issues with PowerTools on CL. Renaming it to powertools does not fix it

Richard G

Verified User
Jul 6, 2008
Mcrypt is deprecated since php 7.1 but you can install it via pecl.
this is for php 7.2 but might also work for php 7.4 when adjusting the commands.

I'm not sure about that so use at your own risk.
I also found this thread, which contains the same information.