Installing problem on Centos 6.3

giorgi91

Verified User
Joined
Oct 22, 2011
Messages
19
I'm installing Directadmin on Centos 6.3

Installing done but Apache does not starting

I get this message when I'm done installing:
*************************************
* *
* All parts have been installed *
* *
*************************************

Type: /sbin/service httpd restart
## REPORT_START
Welcome to DirectAdmin verion 1.42.0!
You are now about to run the install program. If DirectAdmin is already
installed, it may destroy previous data.


Here is the information given:

Admin user: admin
Admin email: admin@srv1.mydomain.com
Server IP: 1.2.3.4
Server IP Netmask: 255.255.255.0
Server Hostname: srv1.mydomain.com
Name Servers:
ns1.mydomain.com
ns2.mydomain.com
options.conf exists, not installing the httpd.conf. Relying on custombuild.
Backup of /etc/proftpd.conf to /etc/proftpd.conf.back successfull
Install of /usr/local/directadmin/data/templates/proftpd.conf to /etc/proftpd.conf successfull
Install of /usr/local/directadmin/data/templates/directadmin.conf to /usr/local/directadmin/conf/directadmin.conf successfull
directory /usr/local/directadmin/data created
directory ./data/admin created
directory /usr/local/directadmin/data/tickets created
directory ./data/users created
directory /home/tmp created
directory /usr/local/directadmin/data/sessions created
directory /etc/virtual created
directory /var/spool/virtual created
directory ./data/admin/ips created
directory ./data/admin/packages created
file ./data/admin/packages.list created
ip.list written successfully
./data/admin/login.hist written successfully
./data/admin/next_ticket.number written correctly
./data/admin/services.status written successfully
tickets.list written successfully
Admin user created
## INSTALL_COMPLETE
## ACCOUNT_INFO


The following information has been set:

Admin username: admin
Admin password: 123123
Admin email: admin@srv1.mydomain.com


Server IP: 1.2.3.4
Server Hostname: srv1.mydomain.com

To login now, follow this link:

http://1.2.3.4:2222

and enter your Admin username and password when prompted.

You should now visit http://admin.site-helper.com and http://www.directadmin.com/newinstall.html to learn how to get started.

Thank you for using DirectAdmin. Should you have any questions, don't hesitate to contact us at support@directadmin.com

## REPORT_END
Permissions set

System Security Tips:
http://help.directadmin.com/item.php?id=247
When I'm trying restart apache I get this:
[root@srv1 ~]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd:
Anyone help me, please


Thanks
 

chatwizrd

Verified User
Joined
Jul 3, 2005
Messages
2,007
So did it start or not. Check /var/log/httpd/error_log

also you can run

Code:
ps xua | grep -i httpd | grep -v grep
netstat -na | grep -i list | grep ':80'
 

BBebow

New member
Joined
Nov 14, 2012
Messages
1
Unable to start also

Just installed the trial version to check it out, I running CentOS 6.3.. Thanks
This is my /var/log/httpd/error_log. Can someone tell me what is up here.

[Wed Nov 14 01:03:03 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 01:03:03 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 01:03:03 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Nov 14 01:03:04 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 01:03:04 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 01:03:04 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips DAV/2 PHP/5.3.18 configured -- resuming normal operations
[Wed Nov 14 01:04:02 2012] [notice] caught SIGTERM, shutting down
[Wed Nov 14 01:04:03 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 01:04:03 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 01:04:03 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Nov 14 01:04:04 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 01:04:04 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 01:04:04 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips DAV/2 PHP/5.3.18 configured -- resuming normal operations
[Wed Nov 14 01:23:42 2012] [notice] caught SIGTERM, shutting down
[Wed Nov 14 01:25:10 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 01:25:10 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 01:25:10 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Nov 14 01:25:11 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 01:25:11 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 01:25:11 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips DAV/2 PHP/5.3.18 configured -- resuming normal operations
[Wed Nov 14 09:02:53 2012] [notice] caught SIGTERM, shutting down
[Wed Nov 14 09:02:54 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 09:02:54 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 09:02:54 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Nov 14 09:02:55 2012] [notice] SSL FIPS mode disabled
[Wed Nov 14 09:02:55 2012] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Nov 14 09:02:55 2012] [notice] Apache/2.2.23 (Unix) mod_ssl/2.2.23 OpenSSL/1.0.0-fips DAV/2 PHP/5.3.18 configured -- resuming normal operations
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,794
Location
A Coruña, Spain
You did not run the others two commands chat wizrd gave you.

Nothing useful from the log.. actually.. should be running...

Regards
 

giorgi91

Verified User
Joined
Oct 22, 2011
Messages
19
So did it start or not. Check /var/log/httpd/error_log
[Sat Nov 17 00:01:37 2012] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Sat Nov 17 00:01:37 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sat Nov 17 00:01:37 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 17 00:01:37 2012] [notice] Digest: done
[Sat Nov 17 00:01:37 2012] [notice] Apache/2.2.15 (Unix) DAV/2 configured -- resuming normal operations
[Sat Nov 17 00:03:40 2012] [notice] caught SIGTERM, shutting down
[Sat Nov 17 00:03:40 2012] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Sat Nov 17 00:03:40 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sat Nov 17 00:03:40 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Nov 17 00:03:40 2012] [notice] Digest: done
[Sat Nov 17 00:03:40 2012] [notice] Apache/2.2.15 (Unix) DAV/2 configured -- resuming normal operations
[Sat Nov 17 00:04:50 2012] [notice] caught SIGTERM, shutting down
[Sat Nov 17 00:04:50 2012] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
ps xua | grep -i httpd | grep -v grep
root 31275 0.1 0.0 204836 8904 ? Ss 00:32 0:00 /usr/sbin/httpd -k start -DSSL
apache 31278 0.0 0.0 204836 5452 ? S 00:32 0:00 /usr/sbin/httpd -k start -DSSL
apache 31279 0.0 0.0 204836 5444 ? S 00:32 0:00 /usr/sbin/httpd -k start -DSSL
apache 31280 0.0 0.0 204836 5444 ? S 00:32 0:00 /usr/sbin/httpd -k start -DSSL
apache 31281 0.0 0.0 204836 5444 ? S 00:32 0:00 /usr/sbin/httpd -k start -DSSL
apache 31282 0.0 0.0 204836 5444 ? S 00:32 0:00 /usr/sbin/httpd -k start -DSSL
netstat -na | grep -i list | grep ':80'
[root@srv1 ~]# netstat -na | grep -i list | grep ':80'
tcp 0 0 :::80 :::* LISTEN
I install it just now, why does not starting apache?
 

chatwizrd

Verified User
Joined
Jul 3, 2005
Messages
2,007
Apache is running fine according to that. You must have a firewall blocking port 80. You should adjust your firewall rules to allow tcp 80.

what do you get with this command:

Code:
/sbin/iptables -L -v
You might need to adjust /etc/sysconfig/iptables

See if this works:

Code:
/sbin/service iptables stop
If it works after you stop the firewall then that means your rules are not right and you need to edit /etc/sysconfig/iptables
 
Last edited:

giorgi91

Verified User
Joined
Oct 22, 2011
Messages
19
Apache is running fine according to that. You must have a firewall blocking port 80. You should adjust your firewall rules to allow tcp 80.

what do you get with this command:

Code:
/sbin/iptables -L -v
You might need to adjust /etc/sysconfig/iptables
I does not installed iptables
 
Top