Ipv6 domain not working on vps


New member
Jun 5, 2023
Hi all,

I have an issue with one of my domains.
On my VPS, I run direct admin with multiple users/websites.

Last week i’ve added a new website which is running fine on my network.

But, for some reason, for some ISP’s the website is not working. Users are getting a time out error.

One of the users did a curl request and got this response;

curl -vvvv http://thdomain.nl
* Trying
* Trying [2a01:7c8:aabd:1d:5054:ff:fe82:6ebb]:80...
* Immediate connect fail for 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb: Network unreachable

So, it looks like it has something to do with ipv6. I’ve assigned the ipv6 domain to my ipv4 domain years ago and as today 35 websites/domains are running fine with exact the same configuration. Except for this new one.

I disabled the firewall and double checked the DNS settings but it’s working.

Do you have any idea where I can look further?
Last edited:
1. all other sites on the same server do connect with ipv6
2. only thdomain.nl doesnt connect with ipv6 but connects over ipv4 ?
right? please share the domain so that forum users can help
DNS test runs all fine, no error in your ipv6 dns setting as far i can see
Ping also works fine :
PING 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb(2a01:7c8:aabd:1d:5054:ff:fe82:6ebb) 56 data bytes
64 bytes from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb: icmp_seq=1 ttl=45 time=225 ms
64 bytes from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb: icmp_seq=2 ttl=45 time=225 ms
64 bytes from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb: icmp_seq=3 ttl=45 time=225 ms
64 bytes from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb: icmp_seq=4 ttl=45 time=225 ms
64 bytes from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb: icmp_seq=5 ttl=45 time=225 ms

--- 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4232ms
rtt min/avg/max/mdev = 225.616/225.646/225.737/0.427 ms

DNS servers37.97.199.195
IPv6-only DNSWorks
Mail exchangers137.97.140.182a01:7c8:aabd:1d:5054:ff:fe82:6ebb
Traceroute give errors:

traceroute to 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb (2a01:7c8:aabd:1d:5054:ff:fe82:6ebb), 30 hops max, 80 byte packets
Maybe it's some routing issue from where you test from with curl to the domain.

I tested on ip6.nl and on internet.nl, all looks fine. However internet.nl had a comment about improvement of ipv6.

Gelijke website op IPv6 en IPv4


Je website op IPv6 lijkt niet gelijk aan je website op IPv4.


Wij vergelijken het antwoord en de inhoud die we van je webserver over IPv6 ontvangen met die over IPv4.
We controleren:
  1. of HTTP (poort 80) en/of HTTPS (poort 443) via IPv4 ook beschikbaar zijn via IPv6;
  2. of HTTP-headers (zoals een redirect-header) via IPv4 ook via IPv6 worden ontvangen;
  3. of HTML-inhoud via IPv4 hetzelfde is via IPv6. Na het strippen van eventuele nonces doen we een vergelijking van de ontvangen inhoud. Het verschil in inhoud mag niet groter zijn dan 10% om voor deze subtest te slagen. De drempel zorgt ervoor dat kleine verschillen (bijvoorbeeld als gevolg van veranderende advertenties) niet leiden tot het falen van deze subtest.
Als er meerdere IPv6- en IPv4-adressen zijn, kiezen we één IPv6-adres en één IPv4-adres om de subtest uit te voeren. Als er alleen een IPv6-adres en geen IPv4-adres beschikbaar is, dan is de subtest niet van toepassing omdat er geen vergelijking kan worden gemaakt.
You don't use mail for that domain/server? Intodns found a missing PTR/rDNS.

ERROR: No reverse DNS (PTR) entries. The problem MX records are: -> no reverse (PTR) detected
You should contact your ISP and ask him to add a PTR record for your ips
and then:
Web server IPv6 connectivity
Trying to get http://www.staffboost.nl from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb...
301 Moved Permanently

Secure web server IPv6 connectivity
Trying to get https://www.staffboost.nl from 2a01:7c8:aabd:1d:5054:ff:fe82:6ebb...
301 Moved Permanently

The path to 'staffboost.nl' using IPv6 is: HOST: li252-216 0
1. 2600:3c01::8678:acff:fe0d:a641 2
2. 2600:3c01:3333:2::1 1
3. 2001:678:34c:65::2 2
4. ae56.r11.sjc01.ien.netarch.akamai.com 3
5. ae-10.r02.snjsca04.us.bb.gin.ntt.net 3
6. ae-11.r24.snjsca04.us.bb.gin.ntt.net 26
7. ae-2.r24.asbnva02.us.bb.gin.ntt.net 64
8. ae-13.r21.parsfr04.fr.bb.gin.ntt.net 142
9. ae-0.r20.parsfr04.fr.bb.gin.ntt.net 142
10. ae-6.r21.amstnl07.nl.bb.gin.ntt.net 153
11. ae-1.a01.amstnl07.nl.bb.gin.ntt.net 174
12. xe-1-5-1-0.a01.amstnl07.nl.ce.gin.ntt.net 147
13. e1-a7.r1.ams0.transip.net 150
14. r1.f2.ams4.transip.net 158
15. f2.l8.ams4.transip.net 161
16. server.roywulms.nl 153
Haha, I finally found the issue.

Initially, I was focused on troubleshooting the IPv6 address, but it turned out that the actual problem resided in the IPv4 address.

When I tried to connect the domain with my server I replaced the previous IP address by selecting it and pasting the new address.

However, it seems that during the selection process, I inadvertently omitted the leading "1" from the previous IP. Consequently, the IP address was changed to instead of the correct value of

Pff.. Give me a break.. 🥴