Let's Encrypt with older Custombuild versions

wtptrs

Verified User
Joined
Jul 13, 2015
Messages
74
Hi, quick question: Is Let's Encrypt supported by Custombuild 1.1 / 1.2?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,097
Location
LT, EU
Let's Encrypt configuration and updates are not offered in CustomBuild 1.1 / 1.2.

To enable it manually, add the following line to /etc/httpd/conf/extra/httpd-alias.conf:
Code:
Alias /.well-known/acme-challenge /var/www/html/.well-known/acme-challenge
Execute:
Code:
mkdir -p /usr/local/directadmin/custombuild/custom/ap2/conf/extra
cp -p /etc/httpd/conf/extra/httpd-alias.conf /usr/local/directadmin/custombuild/custom/ap2/conf/extra/
service httpd restart
echo 'letsencrypt=1' >> /usr/local/directadmin/conf/directadmin.conf
echo 'enable_ssl_sni=1' >> /usr/local/directadmin/conf/directadmin.conf
service directadmin restart
Please also make sure you run the latest version of DirectAdmin.

And that's it :)
 
Top