letsencrypt certificate creation error

ilan

Verified User
Joined
Feb 5, 2004
Messages
48
Location
Mexico City
I tried to create a letsencrypt SSL certificate for an account and I receive the following error message:

Code:
Cannot Execute Your Request

Details

Generating 4096 bit RSA key for let's encrypt account...
openssl genrsa 4096 > "/usr/local/directadmin/data/users/manaliku/letsencrypt.key"
Generating RSA private key, 4096 bit long modulus
..............++
..........................................................................................................................................++
e is 65537 (0x10001)
Account registration error. Response: HTTP/1.1 100 Continue 
Expires: Wed, 03 Aug 2016 03:17:26 GMT 
Cache-Control: max-age=0, no-cache, no-store 
Pragma: no-cache 

HTTP/1.1 400 Bad Request 
Server: nginx 
Content-Type: application/problem+json 
Content-Length: 265 
Boulder-Request-Id: _UyJ6oZfme3h2lZvN51a-BJSYOpq8M4fg-ckWe4msQM 
Replay-Nonce: B-lqG5QiYsn5Tm3Vk3xE6O-0lUgvfgg8mQS1Sbfp2G4 
Expires: Wed, 03 Aug 2016 03:17:26 GMT 
Cache-Control: max-age=0, no-cache, no-store 
Pragma: no-cache 
Date: Wed, 03 Aug 2016 03:17:26 GMT 
Connection: close 

{
"type": "urn:acme:error:malformed",
"detail": "Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.0.1-July-27-2015.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf]",
"status": 400
}.
This same error message I receive on a different server when I tried creating the server certificate using:
Code:
cd /usr/local/directadmin/scripts
./letsencrypt.sh request my.hostname.com 4096
The characteristics of the reserves are:
CentOS 6.5
Linux 2.6.32-431.17.1.el6.x86_64 #1 SMP Wed May 7 23:32:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
OpenSSL 1.0.1e-fips 11 Feb 2013
Apache 2.4.23 (no nginx)
Custombuild 2.0.0 (rev: 1569)

and:
CentOS 6.6
Linux 2.6.32-504.8.1.el6.x86_64 #1 SMP Wed Jan 28 21:11:36 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
OpenSSL 1.0.1e-fips 11 Feb 2013
Apache 2.2.31 (no nginx)
Custombuild 1.2.41

Any suggestions?
 

ilan

Verified User
Joined
Feb 5, 2004
Messages
48
Location
Mexico City
Thanks for you quick reply.

Yes that did it, sorry for posting an existing issue, but the search did not find any of the strings I searched for, and I searched through google using site:directadmin.com to search only here...

In any case, this solved it for me:
Code:
 wget -O /usr/local/directadmin/scripts/letsencrypt.sh http://files1.directadmin.com/services/all/letsencrypt.sh
Thanks
Ilan
 
Top