LetsEncrypt totally broken since Oct 9th, 2019

ozzWANTED

Verified User
Joined
Mar 10, 2015
Messages
12
So Let's Encrypt is fully broken now. It got set without my concent to 'serverscertificate', and if I try to set back to Let's Encrypt I get this errror:

---
Cannot Execute Your Request

Requesting new certificate order...
Nonce is empty. Exiting. dig output of acme-v02.api.letsencrypt.org:
prod.api.letsencrypt.org.
ca80a1adb12a4fbdac5ffcbc944e9a61.pacloudflare.com.
172.65.32.248
Full nonce request output:
HTTP/2 200
server: nginx
date: Sat, 12 Oct 2019 10:31:59 GMT
cache-control: public, max-age=0, no-cache
link: ;rel="index"
replay-nonce: 0002Dmek_bU2vsFUxWGTyXpVM-E_GyljRsWFly-O_tlr3mo
x-frame-options: DENY
strict-transport-security: max-age=604800
---
Updating DA to latest version (1.59) did not helped either - bug is still exist there.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,209
Location
LT, EU
It looks like outdated version of let’s encrypt script.
 

ozzWANTED

Verified User
Joined
Mar 10, 2015
Messages
12
So, running:
---
cd /usr/local/directadmin/custombuild
./build update
./build all d
./build rewrite_confs
----
Solved the problem, and now it all works.
But during the custom build it showed me a message:
----
‘libtool: warning: remember to run 'libtool --finish /usr/local/directadmin/custombuild/php-5.6.40/libs'’
(for clarification I have on DA the PHP (5.6.40) and PHP2 (7.3.10).
----
I tried to run this command before running './build rewrite_confs'
And it said it cannot find it.
Also in DirectAdmin I believe I also have 'CustomBuild 2.0' installed, and if I go to:
'DA Admin -> Extra Features -> CustomBuild 2.0'
I see:
---
Nghttp2 1.37.0 1.39.2
icu4c 64.1 64.2
---
Why these two were not updated?

Also if I loggin to server via Putty, I see this:
---
Welcome to Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-165-generic x86_64)
64 packages can be updated.
1 update is a security update.
---
What should I do? Why DirectAdmin CustomBuild did not updated above, and how to process with that 'security update' and is it safe? It will not break the DA?
Additionally, how can I be sure, that after custombuild the configuration that all users would run their files on user level, and not on the appache did not got reset?
 

ozzWANTED

Verified User
Joined
Mar 10, 2015
Messages
12
Also, as I have my MariaDB running on Separate VPS. While the Hosting Administrators did linked the Database server by the manual. How can I be sure that the custom build does not drop this configuration after update?
 

Active8

Verified User
Joined
Jul 13, 2013
Messages
217
Packages who don't controlled by Custombuild can safely updated by apt-get command.
I assume you use php-fpm that should be ok for the right file permission level
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,217
Location
Maastricht
‘libtool: warning: remember to run 'libtool --finish /usr/local/directadmin/custombuild/php-5.6.40/libs'’
It always does that, also on Centos, you can ignore that line. Might even be run automatically afterwards, I'm not sure, but it's no issue.
 
Top