LibModSecurity connector is only available for nginx right now.

paulonichio

Verified User
Joined
Jul 8, 2019
Messages
10
Hi;

I have an update pending in the CustomBuild of LibModSecurity - but every time I try to update the package to version 3.0.4 the error occurs:

  • Executing /usr/local/directadmin/plugins/custombuild/admin/build libmodsecurity...
  • LibModSecurity connector is only available for nginx right now.

  • Done!

I don't use Ngnix on the server (but Apache), and I can't remove this locked update.
What can be done to correct this?

Thanks!
 

Attachments

jayw1

Verified User
Joined
Nov 20, 2019
Messages
157
Location
USA
I can't find anything on Modsecurity vs LibModsecurity, what's the difference @smtalk ? Can I use Libmodsecurity with OpenLiteSpeed?
I have LibModsecurity install via custombuild but realized I couldn't use it before this bug and couldn't figure out how to remove it.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
I can't find anything on Modsecurity vs LibModsecurity, what's the difference @smtalk ? Can I use Libmodsecurity with OpenLiteSpeed?
I have LibModsecurity install via custombuild but realized I couldn't use it before this bug and couldn't figure out how to remove it.
OpenLiteSpeed has it built-in :)
 

lowhigh

Verified User
Joined
Nov 4, 2014
Messages
13
I everybody!

I'm using CB2 rev 2388, Centos 6.9 Final and nginx_apache. I need Modsecurity for Nginx but i cant not install on some servers, some servers (still CB2 rev 2388, Centos 6.9 Final ) installed successfully but i don't know why, i have to spend much time to investigate but i have no way.
The error at the servers that cannot install Modsecurity always:
Code:
make[1]: Entering directory `/usr/local/directadmin/custombuild/modsecurity-v3.0.4/tools'
Making all in rules-check
make[2]: Entering directory `/usr/local/directadmin/custombuild/modsecurity-v3.0.4/tools/rules-check'
g++ -DHAVE_CONFIG_H -I. -I../../src  -std=c++11 -I../../headers  -I/usr/local/include -DPCRE_HAVE_JIT  -DWITH_MAXMIND -I/usr/local/include   -I/usr/local/include/libxml2 -DWITH_LIBXML2   -g -O2 -MT modsec_rules_check-rules-check.o -MD -MP -MF .deps/modsec_rules_check-rules-check.Tpo -c -o modsec_rules_check-rules-check.o `test -f 'rules-check.cc' || echo './'`rules-check.cc
mv -f .deps/modsec_rules_check-rules-check.Tpo .deps/modsec_rules_check-rules-check.Po
/bin/sh ../../libtool  --tag=CXX   --mode=link g++  -g -O2  -L/usr/local/lib   -L/usr/local/lib -lpcre  -L/usr/lib64/   -L/usr/local/lib -lpcre -o modsec-rules-check modsec_rules_check-rules-check.o ../../src/.libs/libmodsecurity.la -lcurl    -lmaxminddb   -lrt   -L/usr/local/lib -lxml2 -lz -liconv -lm -ldl  -llua-5.1 -L/usr/local/lib -lpcre -lpcre   
libtool: link: g++ -g -O2 -o .libs/modsec-rules-check modsec_rules_check-rules-check.o  -L/usr/local/lib -L/usr/lib64/ ../../src/.libs/libmodsecurity.so -L/usr/lib -lcurl /usr/local/lib/libmaxminddb.so -lrt /usr/local/lib/libxml2.so -lz /usr/local/lib/libiconv.so -lm -ldl -llua-5.1 /usr/local/lib/libpcre.so -Wl,-rpath -Wl,/usr/local/modsecurity/lib
../../src/.libs/libmodsecurity.so: undefined reference to `luaL_loadfilex'
../../src/.libs/libmodsecurity.so: undefined reference to `lua_setglobal'
../../src/.libs/libmodsecurity.so: undefined reference to `lua_pcallk'
../../src/.libs/libmodsecurity.so: undefined reference to `lua_getglobal'
../../src/.libs/libmodsecurity.so: undefined reference to `lua_rawlen'
../../src/.libs/libmodsecurity.so: undefined reference to `luaL_setfuncs'
collect2: error: ld returned 1 exit status
make[2]: *** [modsec-rules-check] Error 1
make[2]: Leaving directory `/usr/local/directadmin/custombuild/modsecurity-v3.0.4/tools/rules-check'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/directadmin/custombuild/modsecurity-v3.0.4/tools'
make: *** [all-recursive] Error 1
I see that the DA on these servers seem doesnot know that it must download Modsecurity-nginx packages like these successfully installed servers but also aways download Mosecurity-v3.04 package.

Please help me!
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
Try: “./build lua”. And see if that changes anything.
 

lowhigh

Verified User
Joined
Nov 4, 2014
Messages
13
Try: “./build lua”. And see if that changes anything.
Hi smtalk!

I have built LUA, upgrade gcc 4.9.1 but the issue is still there.
5 days ago, i easily built on 4 servers that use custombuild rev 2157, 2379
I think build scripts rev 2388 has problem from yesterday.

Please check with me!
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
Hi smtalk!

I have built LUA, upgrade gcc 4.9.1 but the issue is still there.
5 days ago, i easily built on 4 servers that use custombuild rev 2157, 2379
I think build scripts rev 2388 has problem from yesterday.

Please check with me!
Please send access details in PM or ticket, I’ll let you know the cause.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
Your problem was outdated CustomBuild script, configure/modsecurity/configure.modsecurity had no --with-lua=/usr/local. I've also fixed a compatibility issue with CentOS6 in CB 2.0 rev. 2393, but this wasn't the root cause of the problem.
 

lowhigh

Verified User
Joined
Nov 4, 2014
Messages
13
Your problem was outdated CustomBuild script, configure/modsecurity/configure.modsecurity had no --with-lua=/usr/local. I've also fixed a compatibility issue with CentOS6 in CB 2.0 rev. 2393, but this wasn't the root cause of the problem.
Thanks smtalk!

Because of cannot install with LUA so i remove it in the config file. At that time, both have and no have --with-lua=/usr/local also not successfully

But now, after upgrade rev 2396, everythings is OK so i think rev 2388 has issue.

Thanks again!
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
Thanks smtalk!

Because of cannot install with LUA so i remove it in the config file. At that time, both have and no have --with-lua=/usr/local also not successfully

But now, after upgrade rev 2396, everythings is OK so i think rev 2388 has issue.

Thanks again!
I just commented what I've seen on that system :) (why it didn't compile at the time I got access).

As mentioned in the post, there was another issue on CentOS6, which was solved, but on your system it didn't get to that place, as it failed earlier due to missing --with-lua=/usr/local.
 

lowhigh

Verified User
Joined
Nov 4, 2014
Messages
13
I just commented what I've seen on that system :) (why it didn't compile at the time I got access).

As mentioned in the post, there was another issue on CentOS6, which was solved, but on your system it didn't get to that place, as it failed earlier due to missing --with-lua=/usr/local.
With this rev 2396, i even don't need manually install Gcc 4.9 anymore.
Build script do all things for me and work very well

Thanks smtalk!
 
Top