Mail to suspended domains is a permanent error - change to temporary?

kristian

Verified User
Joined
Nov 4, 2005
Messages
100
Location
Norway
Hi,

Currently, an email sent to an address on a suspended domain, results in a permanent error ("550 The domain <domain> is currently suspended. Try later."). When this domain is later unsuspended, those mail will have already bounced, and will not be attempted to be delivered again. Is there a reason for the permanent error, or should this be changed to a temporary error (4xx) to allow for short time account suspension without loss of incoming mail (e.g. late payment)? To me, a temporary error would be preferred, since it's less disruptive.

Looks like this is the relevant code in /etc/exim.conf:

Code:
  drop  message = DOMAIN_SUSPENDED
        domains = +local_domains
        condition = ${if exists{/etc/virtual/${domain}_off}{yes}{no}}
I believe changing the "drop" to "defer" would achieve what I want, but I don't know if this can just be changed like that without any other consequences (and certainly if it'll stick with the next upgrade/rewrite of the exim config).

My exim.conf is "Version 4.5.12", according to the first line.

Does anyone have any insights?
 
Last edited:

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,818
Location
GMT +7.00
Hello Kristian,

I won't comment on why it was designed that way, I simply have no information on the matter.

Be sure, your changes will be lost with a next upgrade if you directly modify /etc/exim.conf. You will need to disable exim.conf upgrades in custombuild options.conf.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
8,904
Hi guys,

Excellent suggestion. I've swapped "drop" to be "defer" in 4.5.12.
It's on files1 now, should be on the other mirrors within 24 hours.

Once your mirror is updated, it should be sufficient to type:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build exim_conf
and to confirm you have it, type:
Code:
[root@server custombuild]# grep DOMAIN_SUSPENDED /etc/exim.conf
  [B]defer[/B]  message = DOMAIN_SUSPENDED
to confirm you see the defer on the left.

As the change it quite minor, I opted for no new version, but future versions will continue to have this change.

John
 
Top