'Maximum execution time of 300 seconds exceeded' when uploading backup in phpMyAdmin

hendrix74

Verified User
Joined
Apr 14, 2005
Messages
35
I've tried to upload a MySQL backup (.sql.gz format, 450kb) through phpMyAdmin. I've tried both phpMyAdmin provided with DA as well as another copy I've installed myself.

I keep getting the error message "Maximum execution time of 300 seconds exceeded".

I don't know why the maximum execution time is set to 300 seconds. I've set "max_execution_time" to 3600 in /usr/local/lib/php.ini and also set "Timeout" to 3600 in /etc/httpd/conf/httpd.conf. The server has even been rebooted since so no need to restart httpd.

When I look at phpinfo() result, it does say that max_execution_time = 3600.

Any ideas?
 

jmstacey

Verified User
Joined
Feb 12, 2004
Messages
4,107
Location
Colorado
The 300 second timeout is Apache's
You can modify that in /etc/httpd/conf/httpd.conf

Just out of curiosity, are you on dialup? Or why is it taking so long for you to upload a 1/2mb file?
 

hendrix74

Verified User
Joined
Apr 14, 2005
Messages
35
Hi,

No I am not on dialup, I'm on cable.

Which parameter do I have to set in httpd.conf?

I've already set Timeout to 3600. I have found no parameters set to 300.

Regards,
Stéphane Brault
 

hendrix74

Verified User
Joined
Apr 14, 2005
Messages
35
I've found the solution!

Yeah!

Found the solution.

Have a look in /var/www/html/phpMyAdmin-2.6.1/config.inc.php
[this might differ from one phpMyAdmin version to another]

There's a var called $cfg['ExecTimeLimit'] which was set to 300 and overided php.ini.

Hope this will be useful to someone else.

I've set it to 3600 but be careful with this ;)
 
Top