Mod_pagespeed on Deb8

Mattpl

Verified User
Joined
Jun 28, 2017
Messages
78
Location
ZS
Hi I need to install this mod_pagespeed. I have download .deb package use command
dpkg -i mod-pagespeed-stable_current_amd64.deb

than I have error with dependeces (in centOs I have add to comand nodeps and install without any errors)
Code:
Preparing to unpack mod-pagespeed-stable_current_amd64.deb ...
Unpacking mod-pagespeed-stable (1.13.35.2-r0) over (1.13.35.2-r0) ...
dpkg: dependency problems prevent configuration of mod-pagespeed-stable:
 mod-pagespeed-stable depends on apache2; however:
  Package apache2 is not installed.

dpkg: error processing package mod-pagespeed-stable (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mod-pagespeed-stable
than I use this command apt-get install -f
and apt want install
apache2 apache2-bin apache2-data apache2-utils libapr1 libaprutil1
libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.1-0 ssl-cert

My question is if apt install another instance of apache and other modules my DA installion will corupt or something?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,855
Location
GMT +7.00
Hello,

You should use a installation from sources if you need it on a directadmin server. Please search the forums for more details.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,855
Location
GMT +7.00
I don't recall any case when I installed pagespeed for Apache2, and I don't have anything in my records for this case yes.

I do have records (1 year old) for NGINX only. And hardly will work for new versions of NGINX.

You've got the idea on what to do, so feel free to do it yourself and share your steps if you want of course.

If you hire me I could install it for you and write detailed instructions for future installs.
 
Top