mod_ruid2 crashing httpd process threads on fresh default install

Willis

Verified User
Joined
Dec 31, 2005
Messages
38
A default install of DA on CentOS 8 (./setup.sh auto) results in apache httpd 2.4(.41) with php 7.2(.24) as mod_php/mpm_prefork with mod_ruid2 enabled.

mod_ruid2 is causing all httpd worker threads to abort, even on static files such as the default static "it's working" pages.

mod_ruid2 compiles with no errors, but causes thread aborts both in mod_php and php-fpm. I understand mod_ruid2 may not recommended on php-fpm, but the default of mod_php I would expect it to work without issue, and it should still at least work with php-fpm (appears to on CentOS 7) even if not recommended.

Currently disabling mod_ruid2 results in working behavior.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
I've changed CustomBuild defaults to PHP-FPM on CentOS8. Thank you for the report!
 

Willis

Verified User
Joined
Dec 31, 2005
Messages
38
The issue here is less that mod_php was the default over php-fpm, but more that mod_ruid2 is enabled by default, and causes either to crash. Are you making a change to the default value for mod_ruid2?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
The issue here is less that mod_php was the default over php-fpm, but more that mod_ruid2 is enabled by default, and causes either to crash. Are you making a change to the default value for mod_ruid2?
Yes, because it'd have mod_ruid2=no as default with php-fpm installation.
 

stephandek

New member
Joined
Mar 23, 2020
Messages
6
When performing this:

cd / usr / local / directadmin / custombuild /
./build update
./build set mod_ruid2 yes
./build mod_ruid2
./build rewrite_confs

Do I get a notification:
mod_ruid2 does not support CentOS8.

Is there a workaround for this??
Now it is so that all cache files are written as apache: apache and not as the user of DA.
This is now causing considerable problems for us

would like to hear
 

Zhenyapan

Verified User
Joined
Feb 23, 2018
Messages
169
Location
UA
When performing this:

cd / usr / local / directadmin / custombuild /
./build update
./build set mod_ruid2 yes
./build mod_ruid2
./build rewrite_confs

Do I get a notification:
mod_ruid2 does not support CentOS8.

Is there a workaround for this??
Now it is so that all cache files are written as apache: apache and not as the user of DA.
This is now causing considerable problems for us

would like to hear
Use php-fpm, not mod_php
 

stephandek

New member
Joined
Mar 23, 2020
Messages
6
Use php-fpm, not mod_php

i am using "php-fpm" under php2_mode, til php4_mod.
i don't think i can use "php-fpm" under php1 if i want to load multiple php versions into DA?


This is my options.conf list what i use and installed.

=========
apache_mpm=auto
apache_ver=2.4
autoconf=no
automake=no
autover=no
awstats=no
blockcracking=no
bold=yes
cagefs=no
clamav_exim=yes
clamav=no
cleanapache=yes
clean_old_tarballs=yes
clean_old_webapps=yes
clean=yes
cloudlinux_beta=no
cloudlinux=no
cron_frequency=daily
cron=yes
curl=no
custombuild=2.0
custombuild_plugin=yes
da_autoupdate=yes
dovecot_conf=yes
dovecot=yes
downloadserver=files.directadmin.com
easy_spam_fighter=no
email=root
eximconf_release=4.5
eximconf=yes
exim=yes
ftpd=pureftpd
harden_symlinks_patch=yes
http_methods=ALL
libtool=no
litespeed_serialno=trial
mail_compress=no
mariadb=10.4
mod_ruid2=yes
modsecurity=no
modsecurity_ruleset=comodo
modsecurity_uploadscan=no
mysql=8.0
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups
mysql_backup_gzip=no
mysql_backup=yes
mysql_force_compile=no
mysql_inst=mariadb
new_pcre=no
notifications=yes
php1_mode=mod_php
php1_release=7.4
php2_mode=php-fpm
php2_release=7.1
php3_mode=php-fpm
php3_release=7.0
php4_mode=php-fpm
php4_release=5.6
php_ini=no
php_ini_type=production
phpmyadmin_public=yes
phpmyadmin_ver=4
"/usr/local/directadmin/custombuild/options.conf"
 

stephandek

New member
Joined
Mar 23, 2020
Messages
6
@ Richard G : this message will be displayed after in the rewrite_conf

@Zhenyapan : is the problem with word not supported also solved under centos8?
 

Zhenyapan

Verified User
Joined
Feb 23, 2018
Messages
169
Location
UA
"problem with word not supported" I don't know what are you talking about, give me link.
 

Zhenyapan

Verified User
Joined
Feb 23, 2018
Messages
169
Location
UA
as you see in the start of this topic - mod_ruid may cause a lot of problems, thats why DA solved this by simplest way - just disables it for centos8, so you can try to install it manually for own risk. But better decision is to use php-fpm.
 

stephandek

New member
Joined
Mar 23, 2020
Messages
6
the cache file will then be rewritten in the correct way. with a configuration like php-fpm? (so under user:user and not as apache: apache)
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
mod_ruid may cause a lot of problems, thats why DA solved this by simplest way - just disables it for centos8,
Where did you get that idea from? Mod_ruid2 has never cause problems, that's pure nonsense and I'm using it on all servers for 12 years.
As far as I could see from other non-directadmin posts, it has to do with Centos 8 OS itself, not with DA disabling it.
Probbly the mod_ruid 0.9.8 needs to be updated, it doesn't work on Centos 8.
 

Zhenyapan

Verified User
Joined
Feb 23, 2018
Messages
169
Location
UA
Where did you get that idea from? Mod_ruid2 has never cause problems, that's pure nonsense and I'm using it on all servers for 12 years.
As far as I could see from other non-directadmin posts, it has to do with Centos 8 OS itself, not with DA disabling it.
Probbly the mod_ruid 0.9.8 needs to be updated, it doesn't work on Centos 8.
as i see mod_ruid2 causes problems with http2, there a lot of messages like that: https://stackoverflow.com/questions/59370491/centos-8-with-vhost-suexec-php-and-http2
so I don't use mod_php in centos8, on centos7 we use it only when clients ask, on centos 6 it was by default + own php-cgi php_version_selector
 

stephandek

New member
Joined
Mar 23, 2020
Messages
6
Unfortunately my question has not been answered yet. Is there another way to run cache files or upload files under the user and not under apache?

instead of apache: apache -> user: user.

it is indeed only the case on CentOS 8 and not under Centos 6 and 7. They handle it well.
 

Nickske00

Verified User
Joined
Nov 30, 2015
Messages
28
Under php-fpm the php process runs as the user, so uploaded files are owned by the user... And like mentioned before, your first php version can also be a php-fpm type...
 
Top