More OLS settings to change

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
I currently use the LiteSpeed WebAdmin to manage OLS but now that I'm transferring over to a DirectAdmin server, I have to find the files to edit.
So, how can I do the following/which files do I edit...

1) Create a Realm to protect an admin area.

2) Edit the Connect Soft/Hard Limit

3) Set "Server Signature" to "Hide Version"

4) View the WebAdmin Console. I know it's readonly but I'd still like to see it. Nothing loads on :7080 which is opened via CSF.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
I see the files, I just don't know what to put in what file.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,483
Location
LT, EU

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
It's not a directory, it's the XenForo admin.php
Woops, I meant 4. Can't see OLS WebAdmin. Just a 503 error.
 

hennaboy

New member
Joined
Jan 9, 2020
Messages
13
Install libnsl to resolve the 503 error.

Wont help you though. Webadmin is readonly due to directadmin splitting the config files into different sections.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
Install libnsl to resolve the 503 error.

Wont help you though. Webadmin is readonly due to directadmin splitting the config files into different sections.
I know it's readonly, I still want to read it.
Good to see you here from CyberPanel.
 

hennaboy

New member
Joined
Jan 9, 2020
Messages
13
I know it's readonly, I still want to read it.
Good to see you here from CyberPanel.
Its a shame its readonly. Would be simple and easier to adjust settings in the webadmin. Alas its taken a day to configure OLS to where it should be. At least where it should be for my requirements.

Ill keep at it. Seems to be going kinda okay....lol
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
Its a shame its readonly. Would be simple and easier to adjust settings in the webadmin. Alas its taken a day to configure OLS to where it should be. At least where it should be for my requirements.

Ill keep at it. Seems to be going kinda okay....lol
Yeah I'm having trouble finding a few settings to change but I'm getting by.
 

hennaboy

New member
Joined
Jan 9, 2020
Messages
13
Let me know what you need to set I think I have it kinda sussed.

The other thread should sort everything out though. Just need to know where the conf is loaded so settings remain intact.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
Let me know what you need to set I think I have it kinda sussed.

The other thread should sort everything out though. Just need to know where the conf is loaded so settings remain intact.
smtalk just helped with one issue, last remaining issues I posted here.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
116
Location
USA
Something else I'm confused about actually. There are expires set in these places:

/usr/local/lsws/conf/httpd-expires.conf
/usr/local/directadmin/custombuild/configure/openlitespeed/conf/httpd-expires.conf

and I've also set custom expires in Direct Admin -> Custom HTTPD Configurations

which of these takes priority? why are there 2 files in the first place?
All config files seem to be duplicated actually. So I'm not sure if I should create custom files, modify one of them, both of them, or something else.
 
Top