Multiphp with mutiple version of modules

anay

Verified User
Joined
Dec 7, 2005
Messages
77
Hello,

I have configured DA with openlightspeed,
I need to have PHP with two version of Phalcon ie. Phalcon 3.4 and Phalcon 4.0.x

So, for PHP 7.1 , I need phalcon 3.4
and for PHP 7.4, I need phalcon 4.0.x

How to do that with DA ?
 

anay

Verified User
Joined
Dec 7, 2005
Messages
77
May be I was not able to explain properly, lets compare with cPanel, if you use easyapache from it, it lets you choose version between what modules / php extension you want with each version of PHP but in in DA I am not able to figure out that how to have some PHP extension not included in a particular version but are there in other php version under multi-php setup.

Advice ?
 

anay

Verified User
Joined
Dec 7, 2005
Messages
77
I have been to that help page but its rather vague. For similar situation, I used to compile or get precompiled extension.so and add it to php.ini . As you can see my concept about compiling things with PHP is not clear. Hence I was looking for some more practical example rather than reference.

Also, can I do that from custombuild GUI included with DA because I suppose having a webhosting control makes life easier, but here its kind of getting complicated.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
Yes I'm sorry. After you replied again I realised that you might be looking for al version selection and my answer was not adequate for that. So that's why I did not gave an additional reply.
I doubt if a version selection can be done that way. We have to wait an answer from somebody else.
 

anay

Verified User
Joined
Dec 7, 2005
Messages
77
So I assume there is no way to do it easily, can we put this on feature request ?
 
Top