MX Records not Working

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
The problem is that MX Records aren’t working properly, I’m trying to activate G Suites but Gmail cannot be activated because supposedly MX Records are missing (but all are there correctly) Looks like there is an issue with the MX records platform (Directadmin)
 

floyd

Verified User
Joined
Mar 29, 2005
Messages
5,315
Give us your domain so we can check it for you.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
Seems you're running external nameservers for that domain, or am I mistaken? Did you create the correct MX records in those DNS settings?
Because at this moment the MX records point to ipage.com.
And if you use external DNS, then the local DNS settings in Directadmin don't change anything.
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
Thanks for you help. I understand I did it right. Because the platform have an option to create all the MX records of G Suites automatically.

i attached a picture to show you what I have right now.

Seems you're running external nameservers for that domain, or am I mistaken? Did you create the correct MX records in those DNS settings?
Because at this moment the MX records point to ipage.com.
And if you use external DNS, then the local DNS settings in Directadmin don't change anything.
 

floyd

Verified User
Joined
Mar 29, 2005
Messages
5,315
That does not appear to be a DirectAdmin screen so not a DirectAdmin problem.
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
Is there a way that a direct admin representative can help... because they doesn’t answer my emails
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,565
@radhamesda, You are a customer at freehosting.com, you must contact freehosting.com about this. Nobody else can help you.
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
What can I do if they don’t answer. I have been trying to contact them for more than 20’days and even paid for ticket service and even that they don’t answer.
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
I need help from the direct admin technicians. Can someone open a ticket for me and let them know than my provider free hosting doesn’t answer my request to contact direct admin to solve an issue with my Mx records platform. My domain is fedoken.org
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
I can’t open a ticket because my host is supposed to do it. I’m stock because of the really bad service of Freehosting.com... I even paid 10 usd to open a technical support ticket and they don’t answer.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
10 usd to open a technical support ticket? OMG. And then no support? I would switch hosts as soon as possible.
Because the platform have an option to create all the MX records of G Suites automatically.
Ah yes, they have the same for office365.
Normally at the same page where you can set this, there is also another option:

Use this server to handle my emails.
If not, change the MX record and uncheck this option

Did you remember to uncheck this option? Otherwise it still will handle mail locally and not via Gmail.
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
Thanks for your help.
yes I did uncheck that, but still having problem with the MX.... even the old MX records aren’t there..

10 usd to open a technical support ticket? OMG. And then no support? I would switch hosts as soon as possible.

Ah yes, they have the same for office365.
Normally at the same page where you can set this, there is also another option:

Use this server to handle my emails.
If not, change the MX record and uncheck this option

Did you remember to uncheck this option? Otherwise it still will handle mail locally and not via Gmail.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
In that case I would like to point back at my reply in post #4.
Did you copy all those DA settings also into your external nameserver DNS settings? Because what you setup in DA does not take any effect if you do not copy them to your external nameserver dns settings.
 

radhamesda

New member
Joined
Mar 7, 2020
Messages
12
Thanks for your help .
yes i did all your recommendations but didn’t work.

I’m sure that there is a problem with them, because before I could see my old MX records... and now I cant.
In that case I would like to point back at my reply in post #4.
Did you copy all those DA settings also into your external nameserver DNS settings? Because what you setup in DA does not take any effect if you do not copy them to your external nameserver dns settings.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
I’m sure that there is a problem with them,
Yes but since you're using external nameservers it's not a Directadmin issue but an issue with the provider of the external nameservers.

If that is the company you mentioned which do not reply to tickets or mails, I would again advised to change hoster asap. We can't help you with correctly setup dns settings in an external mailserver.
 
Top