MySQL DBs d'on't work

Thafusion

Verified User
Joined
Oct 8, 2003
Messages
52
i made a admin
with the admin a reseller
and then a user called
login test1 ,pass testtest

then i made a database

PHP:
Database Created
Details
Your database has been setup. Use the following values:
Database: test1_data 
Host: localhost 
Username: test1_test 
Password: testdatabase
then i wanted to log on with ip/phpMyAdmin/

i typed
test1_test
testdatabase

didn't work
also test1 testtest
test1_data testdatabase

everything dodn't work :(
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

You probably have a mysql.sock file located somewhere where DA knows to find it, but nothing else does. If you have one, check your /etc/my.cnf file to see the location of the mysql.sock file. DirectAdmin looks in /var/lib/mysql/mysql.sock for it, but phpMyAdmin might be looking in /tmp/mysql.sock.

Easy fix:
If /var/lib/mysql/mysql.sock exists, create a symbolic link to it from /tmp/mysql.sock
Code:
cd /tmp
ln -s /var/lib/mysql/mysql.sock .
John
 

Sentinel

Verified User
Joined
Nov 3, 2003
Messages
25
Location
Portugal
Problem

I had the same problem. I did what you said up top, and yeah, sure, I can log in now. BUT, the only thing it shows me now are the frames but no page... ??

-The Sentinel
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

There is a weird php bug for some people with output buffering. By turning it off, it should work. Just paste the following into your command line as root:
Code:
/usr/bin/perl -pi -e 's/\$mode = 1;/\$mode = 0;/' /var/www/html/phpMyAdmin-2.5.0/libraries/ob.lib.php
John
 
Top