named crashing after installing spamassassin and easy spam fighter

chwba

Verified User
Joined
Dec 23, 2019
Messages
29
I followed https://help.directadmin.com/item.php?id=36 and https://help.directadmin.com/item.php?id=576

My goal was to install Easy Spam Fighter and SpamAssassin - After I had followed the how-tos linked above named fails to start. Im running CentOS

journalctl:
Code:
/bin/bash: /usr/sbin/named-checkconf: No such file or directory
named.service: control process exited, code=exited status=127
Failed to start Berkeley Internet Name Domain (DNS).
and in exim/mainlog I see this:
Code:
2020-01-21 03:00:20 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=up2date@myurl.io)                                                        │
2020-01-21 03:00:54 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=update@myurl.io)                                                         │
2020-01-21 03:01:27 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=upload@myurl.io)                                                         │
2020-01-21 03:02:01 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=users@myurl.io)                                                          │
2020-01-21 03:02:34 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=usher@myurl.io)                                                          │
2020-01-21 03:03:08 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=usr@myurl.io)                                                            │
2020-01-21 03:03:38 cwd=/var/spool/exim 2 args: /usr/sbin/exim -qG                                                                                                                              │
2020-01-21 03:03:41 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=valid@myurl.io)                                                          │
2020-01-21 03:04:15 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=vampire@myurl.io)                                                        │
2020-01-21 03:04:49 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=vhost@myurl.io)                                                          │
2020-01-21 03:05:24 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=village@myurl.io)                                                        │
2020-01-21 03:05:58 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=viper@myurl.io)                                                          │
2020-01-21 03:06:32 login authenticator failed for (User) [151.151.78.1.7]: 535 Incorrect authentication data (set_id=virtual@myurl.io)
Any other log that I could provide which would help to find the solution?
 
Last edited:

toml

Verified User
Joined
Oct 3, 2003
Messages
1,197
Location
Scottsdale, AZ
Do you have bind installed? It should be according to the pre-install commands (https://help.directadmin.com/item.php?id=354). When I do a 'rpm -ql bind' I see that file (/usr/sbin/named-checkconf) was installed. It is missing for some reason on your system, either make sure all the pre-install packages are installed before continuing or re-install bind if it was already installed.
 

chwba

Verified User
Joined
Dec 23, 2019
Messages
29
Bind was indeed not installed, everything else was. So now it is installed and when I do service restart named it failed to start again with an error, that the firewall is blocking it. - So I disabled the firewall and tried again now I get this:

Code:
n 21 15:11:28 server.myurl.io polkitd[1167]: Unregistered Authentication Agent for unix-process:28125:51282379 (system bus name :1.25444, object path /org/freedesktop/PolicyKit1
Jan 21 15:11:28 server.myurl.io sshd[28118]: Failed password for invalid user render from 151.151.78.1.7 port 35936 ssh2
Jan 21 15:11:29 server.myurl.io sshd[28118]: Received disconnect from 151.151.78.1.7 port 35936:11: Bye Bye [preauth]
Jan 21 15:11:29 server.myurl.io sshd[28118]: Disconnected from 151.151.78.1.7 port 35936 [preauth]
 

toml

Verified User
Joined
Oct 3, 2003
Messages
1,197
Location
Scottsdale, AZ
None of those are related to named at all. 3 are ssh errors and another is for polkit. The firewall may be blocking outside queries to named but it won't prevent it from started. If the firewall is blocking, you need the command for the firewall you are using to open port 53 which is what named uses.
 

chwba

Verified User
Joined
Dec 23, 2019
Messages
29
But I completely disabled the firewall (csf -x) for the purpose of testing this. I wonder where the service is trying to connect to and why do I see "Unregistered Authentication Agent", any idea?

Also do you have a clue where email addresses from the exim log are coming from? I certainly never created those myself.
 

toml

Verified User
Joined
Oct 3, 2003
Messages
1,197
Location
Scottsdale, AZ
"Unregistered Authentication Agent" has nothing to do with named (https://stackoverflow.com/questions...-of-polkitd-unregistered-authentication-agent). There is something else causing named to not load, and only looking at your log files closely will you figure it out. Typically in the past when I have had named fail to load, it was due to not having proper permissions to either the repository directory or the log file/directory.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,589
Location
Maastricht
/bin/bash: /usr/sbin/named-checkconf: No such file or directory
Just try named-checkconf from ssh commandline, without the /user/sbin in front of it.
Should be in your path and start. Or use locate or find to find it.
If it's not present, then your bind installation is not complete, which couls also be a cause for not starting.

Another cause could be a zone containing a not allowed character.
You might try to check this with named-checkzone if you have bind-utils installed.

If you are on Centos, try
Code:
yum reinstall bind bind utils
to fix this. The named-checkzone command should be present then too.[/code]
 
Last edited:

chwba

Verified User
Joined
Dec 23, 2019
Messages
29
This fixed it. The reason was, that I had a newer geoip update package installed through which I was not able to install the distros geoip package which also seems to include a libGeoIP.so.1 that apparently is required to build bind.

The reason for me having this version installed is, that I was trying to setup the MaxMindGeoIP databases by following the following guides:

I wonder how else one would make this work.
 
Top