"named" service stopped

mateusz

New member
Joined
Mar 19, 2020
Messages
5
Hi,
I'm beginner and I have "named" service stopped.
When I try to start it, I get: error

/bin/systemctl start named.service >/dev/null 2>&1


Ani suggestions what should I do?

Thanks,
Mat
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
The line you posted is some kind of command line, it's not an error message.

How to you try to start named? Via the panel? If yes, login via SSH and start via commandline:
service start named
then check if and which error notice you get.

Also check your system logs for error messages, for Centos this is /var/log/messages you can look in to.
 

mateusz

New member
Joined
Mar 19, 2020
Messages
5
Thank you for fast reply!
I'm using Debian-10-x86_64 on VPS.

Error I'm getting in DirectAdmin (Admin Tools > Service Monitor) after clicking on "Start" for service "named".
I've tried to start it via DirectAdmin Service Monitor only...

When I put via ssh: "service start named"
I get: "start: unrecognized service"
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
When I put via ssh: "service start named"
I get: "start: unrecognized service"
Oke I did not know you were using Debian.
In that case it's probably the command:
service start bind

Anyway, you fixed that part.

For the script to be working, you should have running nameservers to begin with. So are you running local nameservers with 2 different ip addresses at least on your VPS?

If yes, check your /etc/named.conf decently, it could wel be one of the first lines is:
Code:
allow-transfer {"none";};
because that's added by default by Directadmin installation.
So if you add the "allow-transfer { myIP; }; " line it can cause errors, so check you're not using double commands.
I presume the "myIP" mentioned here is the IP you got from ClouDNS.

Be aware with that last }; which you don't need to place yourself at that place, because that would be the closing tag of your "options" statement which is already closed somewhere later in the file. Check it.
You probably only need to do what you did, but remove the last closing tag with semicolumn, so the last }; to make things working.
 

mateusz

New member
Joined
Mar 19, 2020
Messages
5
Thanks! Case solved...

I'm using VPS with DirectAdmin with one IP as Master Zone and ClouDNS for Secondary.
I've needed to add IPs to DirectAdmin.

Errors came because I had more than one file named.conf: I've had named.conf and named.conf.options
And I was trying to put "Options" to the first one... not the second one.


Thanks for helping once more!
 
Top