Need help with git

sittipong

New member
Joined
Jan 30, 2014
Messages
1
I was install git via sudo yum install git, it was done but with some error.

Code:
git: /usr/local/lib/libz.so.1: no version information available (required by git)
After I search for a while, I found this solution in DirectAdmin Help. But not yet do it cause they said We do not recommend using the options below.
.
Please help me how can to solve it, thanks. :)
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,580
I would advice against upgrading zlib, I have tested it before, and it caused all kind of problems. Default in custombuild is now to let the OS handle the installation of zlib.

However, it should be safe to upgrade libxml2, I am running the newest version of libxml2 and libxslt without problems. It might not solve your problem, but it would not hurt to try. To upgrade libxml2 and libxslt do this:

Edit /usr/local/directadmin/custombuild/options.conf and set this value:
Code:
new_xml2=yes
Then do this:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build libxml2
./build libxslt
./build php n
 
Last edited:

ericovk

Verified User
Joined
Apr 17, 2012
Messages
219
Location
Rotterdam, Netherlands
I am getting the same error when I try to get
Code:
[I]git clone http://github.com/ry/node.git && cd node[/I]
libz doesn't seem to be updated /usr/local/lib/libz.so.1.2.3 after actions taken as described above.

Anyway, it seems I got the wrong url from the installation guide. http:// is not supported when cloning git, it had to be https://
 
Last edited:
Top