No package perl-IP-Country available.

alipour66m

Verified User
Joined
Feb 22, 2013
Messages
65
I'm going to install spamassassin

i run
Code:
yum -y install perl-ExtUtils-MakeMaker perl-Digest-SHA perl-Net-DNS perl-NetAddr-IP perl-Archive-Tar perl-IO-Zlib perl-Digest-SHA perl-Mail-SPF \
perl-IP-Country perl-Razor2 perl-Net-Ident perl-IO-Socket-INET6 perl-IO-Socket-SSL perl-Mail-DKIM perl-DBI perl-Encode-Detect perl-HTML-Parser \
perl-HTML-Tagset perl-Time-HiRes perl-libwww-perl perl-Sys-Syslog perl-DB_File perl-Razor-Agent pyzor
The 5 package not installed

No package perl-IP-Country available.
No package perl-Razor2 available.
No package perl-Net-Ident available.
No package perl-Sys-Syslog available.
No package perl-DB_File available.

Can I continue and bulid spamassassin ?

Code:
cd /usr/local/directadmin/custombuild
./build set spamd spamassassin
./build spamassassin
 

Erulezz

Verified User
Joined
Sep 14, 2015
Messages
433
Location
Arnhem, NL
Did you add the epel-release repo?

Code:
yum install epel-release
Those packages are in the epel repository.
 

alipour66m

Verified User
Joined
Feb 22, 2013
Messages
65
Did you add the epel-release repo?

Code:
yum install epel-release
Those packages are in the epel repository.
Installed , But problem still exists.

No package perl-IP-Country available.
No package perl-Razor2 available.
No package perl-Net-Ident available.
No package perl-Sys-Syslog available.
No package perl-DB_File available.
 

alipour66m

Verified User
Joined
Feb 22, 2013
Messages
65
Can you please help me to install them manually?

Code:
yum -y install perl-Razor2
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
No package perl-Razor2 available.
Error: Nothing to do
 
Last edited:

alipour66m

Verified User
Joined
Feb 22, 2013
Messages
65
Have a look at this, you could install them via CPAN:

https://forum.directadmin.com/showthread.php?t=47307

Or better, use the repoforge repository which contains them:
http://repoforge.org/use/


[root@server ~]# yum -y install perl-ExtUtils-MakeMaker perl-Digest-SHA perl-Net-DNS perl-NetAddr-IP perl-Archive-Tar perl-IO-Zlib perl-Digest-SHA perl-Mail-SPF perl-IP-Country perl-Razor2 perl-Net-Ident perl-IO-Socket-INET6 perl-IO-Socket-SSL perl-Mail-DKIM perl-DBI perl-Encode-Detect perl-HTML-Parser perl-HTML-Tagset perl-Time-HiRes perl-libwww-perl perl-Sys-Syslog perl-DB_File perl-Razor-Agent pyzor
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
* rpmforge: ftp.nluug.nl
Package perl-ExtUtils-MakeMaker-6.55-144.el6.x86_64 already installed and latest version
Package 1:perl-Digest-SHA-5.47-144.el6.x86_64 already installed and latest version
Package perl-Net-DNS-0.65-5.el6.x86_64 already installed and latest version
Package perl-NetAddr-IP-4.027-7.el6.x86_64 already installed and latest version
Package perl-Archive-Tar-1.58-144.el6.x86_64 already installed and latest version
Package 1:perl-IO-Zlib-1.09-144.el6.x86_64 already installed and latest version
Package 1:perl-Digest-SHA-5.47-144.el6.x86_64 already installed and latest version
Package perl-Mail-SPF-2.8.0-2.el6.noarch already installed and latest version
No package perl-Razor2 available.
Package perl-IO-Socket-INET6-2.56-4.el6.noarch already installed and latest version
Package perl-IO-Socket-SSL-1.31-3.el6_8.2.noarch already installed and latest version
Package perl-Mail-DKIM-0.37-2.el6.noarch already installed and latest version
Package perl-DBI-1.609-4.el6.x86_64 already installed and latest version
Package perl-Encode-Detect-1.01-2.el6.x86_64 already installed and latest version
Package perl-HTML-Parser-3.64-2.el6.x86_64 already installed and latest version
Package perl-HTML-Tagset-3.20-4.el6.noarch already installed and latest version
Package 4:perl-Time-HiRes-1.9721-144.el6.x86_64 already installed and latest version
Package perl-libwww-perl-5.833-5.el6.noarch already installed and latest version
Package perl-Razor-Agent-2.85-6.el6.x86_64 already installed and latest version
Package pyzor-0.5.0-3.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package perl-DB_File.x86_64 0:1.827-1.el6.rf will be installed
---> Package perl-IP-Country.noarch 0:2.27-1.el6.rf will be installed
--> Processing Dependency: perl(Geography::Countries) for package: perl-IP-Country-2.27-1.el6.rf.noarch
---> Package perl-Net-Ident.noarch 0:1.23-1.el6.rf will be installed
---> Package perl-Sys-Syslog.x86_64 0:0.27-1.el6.rf will be installed
--> Running transaction check
---> Package perl-Geography-Countries.noarch 0:2009041301-1.el6.rf will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================
Package Arch Version Repository Size
=============================================================================================================================================================================================
Installing:
perl-DB_File x86_64 1.827-1.el6.rf rpmforge 126 k
perl-IP-Country noarch 2.27-1.el6.rf rpmforge 211 k
perl-Net-Ident noarch 1.23-1.el6.rf rpmforge 26 k
perl-Sys-Syslog x86_64 0.27-1.el6.rf rpmforge 60 k
Installing for dependencies:
perl-Geography-Countries noarch 2009041301-1.el6.rf rpmforge 17 k

Transaction Summary
=============================================================================================================================================================================================
Install 5 Package(s)

Total size: 439 k
Installed size: 989 k
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
file /usr/share/man/man3/Sys::Syslog.3pm.gz from install of perl-Sys-Syslog-0.27-1.el6.rf.x86_64 conflicts with file from package perl-4:5.10.1-144.el6.x86_64
file /usr/share/man/man3/DB_File.3pm.gz from install of perl-DB_File-1.827-1.el6.rf.x86_64 conflicts with file from package perl-4:5.10.1-144.el6.x86_64

Error Summary
-------------
 

alipour66m

Verified User
Joined
Feb 22, 2013
Messages
65
RepoForge might be outdated. We have no updates since very long time.
I removed it by :
Code:
rpm -e rpmforge-release-0.5.3-1.el6.rf.x86_64
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,217
Location
Maastricht
RepoForge might be outdated.
Hmmz.. that could be true, I read on some websites not to use epel anymore for that or other (maybe incompatibility? I don't remember) reasons and to switch to repoforge.
At least Epel did not contain some of the packages for Spamassassin which Repoforge does as you can see from your output. ;)
If they have older stuff that's not a benefit indeed. It's a choice you have to make yourself.

@Trix.hosting: Yep, that was stated in the first line of my reply. I used that before too, but some modules can conflict with other yum perl modules for some other apps, that's why I'm trying other repo's nowadays.

Edit: Just checked. I'm back using epel with Cpan again. ;)
 
Last edited:
Top