not able to compile exim

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
Hi,
my error as follows:
Please install ExtUtils::Embed for /usr/bin/perl
grep: Makefile: No such file or directory
Missing CFLAGS_DYNAMIC inhibits building dynamic module lookup
../scripts/lookups-Makefile: line 115: lookups/Makefile.predynamic: No such file or directory

i tried hunting for a solution high and low but can't seem to find any. i can't install the perl module through cpan. anybody has a resolution to it?

the weird thing is i already installed ExtUtils::Embed via source and it shows up in the Perl modules in the control panel.
 

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
hi,
there's no such package in debian. :)
i read a page in help.directadmin.com before coming here.
thanks.
 

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
Running install for module 'ExtUtils::Embed'
CPAN: Data::Dumper loaded ok (v2.124)
'YAML' not installed, falling back to Data::Dumper and Storable to read prefs '/root/.cpan/prefs'
The most recent version "1.30" of the module "ExtUtils::Embed"
is part of the perl-5.15.4 distribution. To install that, you need to run
force install ExtUtils::Embed --or--
install F/FL/FLORA/perl-5.15.4.tar.gz
CPAN: Time::HiRes loaded ok (v1.9719)
Running make test
Can't test without successful make
Running make install
Make had returned bad status, install seems impossible
 

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
pal, i really appreciate your help but i had really tried all available methods on both help.directadmin.com, this forum and google. none gave me an answer that's why i post it here. :)
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,794
Location
A Coruña, Spain
Well it say you need to update perl or force it, so.. lets force it...

Code:
echo "no"  | /usr/bin/perl -MCPAN -e "CPAN::Shell->force(qw(install ExtUtils::Embed));"
Regards
 

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
this will in turn install perl 5.15.4? no?
i read that it's not for production purpose. anyway i'm trying to see how it turns out.
thanks.
 

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
Well it say you need to update perl or force it, so.. lets force it...

Code:
echo "no"  | /usr/bin/perl -MCPAN -e "CPAN::Shell->force(qw(install ExtUtils::Embed));"
Regards
did this but still failed. error:

CPAN: File::Temp loaded ok (v0.22)
CPAN: Time::HiRes loaded ok (v1.9719)

CPAN.pm: Going to build F/FL/FLORA/perl-5.15.4.tar.gz

Say 'sh Configure', not 'sh <Configure'
Warning: No success on command[/root/.cpan/build/perl-5.15.4-sndfZL/Configure]
Warning (usually harmless): 'YAML' not installed, will not store persistent state
FLORA/perl-5.15.4.tar.gz
/root/.cpan/build/perl-5.15.4-sndfZL/Configure -- NOT OK
Running make test
Make had some problems, won't test
Running make install
Make had some problems, won't install
Could not read '/root/.cpan/build/perl-5.15.4-sndfZL/META.yml'. Falling back to other methods to determine prerequisites
 

weeliat

Verified User
Joined
Mar 18, 2012
Messages
11
yeah thanks for your offer to help.
i guess i'll wait a bit till someone encounters the same trouble and hopefully a fix be out by then.
 
Top