opcache only for some virtualhosts on a server with 2 php version

jonium

Verified User
Joined
Nov 10, 2010
Messages
129
Location
Alezio - Lecce- Apulia - South Italy
Hello,
I have the following configuration and need to activate opcache only on php 7.2 and only on some virtualhosts (through .user.ini if possible)

Code:
# cat options.conf
#PHP Settings
php1_release=5.6
php1_mode=mod_php
php2_release=7.2
php2_mode=php-fpm
opcache=no
htscanner=no
php_ini=no
php_timezone=Europe/Rome
php_ini_type=production
ioncube=no
zend=no
suhosin=yes
x_mail_header=yes

#MySQL Settings
mysql=5.6
mariadb=10.0
mysql_inst=mariadb
mysql_backup=yes
mysql_backup_gzip=no
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups
mysql_force_compile=no

#WEB Server Settings
webserver=apache
litespeed_serialno=trial
modsecurity=yes
modsecurity_ruleset=comodo
apache_ver=2.4
apache_mpm=auto
mod_ruid2=yes
userdir_access=yes
harden_symlinks_patch=yes
use_hostname_for_alias=auto
redirect_host=*****
redirect_host_https=no

#WEB Applications Settings
phpmyadmin=yes
phpmyadmin_ver=4
squirrelmail=yes
roundcube=yes
webapps_inbox_prefix=no

#ClamAV-related Settings
clamav=yes
clamav_exim=yes
modsecurity_uploadscan=yes
proftpd_uploadscan=no
pureftpd_uploadscan=yes
suhosin_php_uploadscan=no

#Mail Settings
exim=yes
eximconf=yes
eximconf_release=4.5
blockcracking=yes
easy_spam_fighter=yes
spamd=spamassassin
sa_update=daily
dovecot=yes
dovecot_conf=yes
pigeonhole=no

#FTP Settings
ftpd=pureftpd

#Statistics Settings
awstats=no
webalizer=yes

#CustomBuild Settings
custombuild=2.0
autover=yes
bold=yes
clean=yes
cleanapache=yes
clean_old_tarballs=yes
clean_old_webapps=yes
downloadserver=files24.directadmin.com

#Cronjob Settings
cron=yes
cron_frequency=daily
email=***
notifications=yes
da_autoupdate=yes
updates=yes
webapps_updates=yes

#CloudLinux Settings
cloudlinux=no
cloudlinux_beta=no
cagefs=no

#Advanced Settings
autoconf=yes
automake=yes
libtool=yes
curl=yes
new_pcre=yes

http_methods=GET:HEAD:POST
secure_php=no
How to do it? and how to activate http/2?
 
Top