Option ExecCGI not allowed here - .htaccess broken my images

tonymontana

Verified User
Joined
Dec 30, 2017
Messages
12
Hi All,

I am rookie with server develop but try provide own VPS serwer.
I use DirectAdmin on Debian and have many sites on Drupal CMS.

In ma case, I have problem with images because .htacees files stop showing images.
When I delete .htaccess file, then images are workind.
In error log I have:

.htaccess: Option ExecCGI not allowed here, referer: domain.pl

Ofcourse I looking solution before write here:

But this don't work for me.
Maybe I'm doing something wrong?

Can someone write me step by step what should I do?

Thank you for all replies.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,774
Location
LT, EU
Why did you add "Option ExecCGI" to .htaccess in the first place? :) As it's not needed there for images.
 

tonymontana

Verified User
Joined
Dec 30, 2017
Messages
12
Hi smtalk

System automaticaly create .htaccess files with this content:

Code:
# Turn off all options we don't need.
Options -Indexes -ExecCGI -Includes -MultiViews

# Set the catch-all handler to prevent scripts from being executed.
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006
<Files *>
  # Override the handler again if we're run later in the evaluation list.
  SetHandler Drupal_Security_Do_Not_Remove_See_SA_2013_003
</Files>

# If we know how to do it safely, disable the PHP engine entirely.
<IfModule mod_php5.c>
  php_flag engine off
</IfModule>
When I remove -ExecCGI images still don't work.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,774
Location
LT, EU
I'd suggest reporting it as a bug to CMS creator, as they cannot be sure that virtualhost allows operating the options they're adding there.
 

tonymontana

Verified User
Joined
Dec 30, 2017
Messages
12
This is very strange, because of others hosting this CMS work fine.
Maybe my configurations are wrong?
Can I check this?
 
Top